summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-08-22 22:30:46 +0000
committerSteve Dibb <beandog@gentoo.org>2009-08-22 22:30:46 +0000
commit4e059df45851d283ebf5ca07bb20c535df57b6d7 (patch)
tree4a0ecd51aaf00348a2db9f2aa816a5b9cf6311e6 /dev-php/PEAR-Auth
parentRemove ruby16 and ruby19 from USE_RUBY. (diff)
downloadgentoo-2-4e059df45851d283ebf5ca07bb20c535df57b6d7.tar.gz
gentoo-2-4e059df45851d283ebf5ca07bb20c535df57b6d7.tar.bz2
gentoo-2-4e059df45851d283ebf5ca07bb20c535df57b6d7.zip
Version bump
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-Auth')
-rw-r--r--dev-php/PEAR-Auth/ChangeLog9
-rw-r--r--dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-php/PEAR-Auth/ChangeLog b/dev-php/PEAR-Auth/ChangeLog
index 8261ad4f5577..9ab9a8eaa4ff 100644
--- a/dev-php/PEAR-Auth/ChangeLog
+++ b/dev-php/PEAR-Auth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-Auth
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/ChangeLog,v 1.41 2007/12/05 23:31:53 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/ChangeLog,v 1.42 2009/08/22 22:30:46 beandog Exp $
+
+*PEAR-Auth-1.6.1 (22 Aug 2009)
+
+ 22 Aug 2009; Steve Dibb <beandog@gentoo.org> +PEAR-Auth-1.6.1.ebuild:
+ Version bump
05 Dec 2007; Markus Ullmann <jokey@gentoo.org> -PEAR-Auth-1.2.4.ebuild,
PEAR-Auth-1.5.4.ebuild:
diff --git a/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild b/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild
new file mode 100644
index 000000000000..45ae6ac13dd4
--- /dev/null
+++ b/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild,v 1.1 2009/08/22 22:30:46 beandog Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+DESCRIPTION="Provides methods for creating an authentication system using PHP."
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal"
+RDEPEND="!minimal? ( >=dev-php/PEAR-Log-1.9.10
+ >=dev-php/PEAR-File_Passwd-1.1.0
+ >=dev-php/PEAR-Net_POP3-1.3.0
+ >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-MDB
+ >=dev-php/PEAR-MDB2-2.0.0_rc1
+ >=dev-php/PEAR-Crypt_CHAP-1.0.0
+ >=dev-php/PEAR-SOAP-0.9.0
+ >=dev-php/PEAR-File_SMBPasswd-1.0.0 )"
+ # missing lots of keywords
+ # >=dev-php/PEAR-HTTP_Client-1.1.0
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! built_with_use --missing true =${PHP_PKG} imap soap ; then
+ elog "${PN} can optionally use ${PHP_PKG} imap and soap features."
+ elog "If you want those, recompile ${PHP_PKG} with these flags in USE."
+ fi
+}