summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-05 05:10:52 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-05 05:10:52 +0000
commitcf477bda48984dc72bc4f20771544005ebbe493a (patch)
tree8a9df3ca98840f259c8a223524f206ddc09afc29 /dev-php/PEAR-Log
parentMarked ppc/ppc64 stable for bug #284453. (diff)
downloadgentoo-2-cf477bda48984dc72bc4f20771544005ebbe493a.tar.gz
gentoo-2-cf477bda48984dc72bc4f20771544005ebbe493a.tar.bz2
gentoo-2-cf477bda48984dc72bc4f20771544005ebbe493a.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/ChangeLog9
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.11.6.ebuild25
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-php/PEAR-Log/ChangeLog b/dev-php/PEAR-Log/ChangeLog
index d275d694ea50..40ef998a4ef2 100644
--- a/dev-php/PEAR-Log/ChangeLog
+++ b/dev-php/PEAR-Log/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-Log
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/ChangeLog,v 1.83 2009/08/22 19:46:10 beandog Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/ChangeLog,v 1.84 2010/01/05 05:10:52 yngwin Exp $
+
+*PEAR-Log-1.11.6 (05 Jan 2010)
+
+ 05 Jan 2010; Ben de Groot <yngwin@gentoo.org> +PEAR-Log-1.11.6.ebuild:
+ Version bump
*PEAR-Log-1.11.5 (22 Aug 2009)
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.11.6.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.11.6.ebuild
new file mode 100644
index 000000000000..ea7fda99ab01
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.11.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/PEAR-Log-1.11.6.ebuild,v 1.1 2010/01/05 05:10:52 yngwin Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="The Log framework provides an abstracted logging system.
+It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal targets."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-Mail
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! built_with_use --missing true =${PHP_PKG} sqlite ; then
+ elog "${PN} can optionally use ${PHP_PKG} sqlite features."
+ elog "If you want those, recompile ${PHP_PKG} with this flag in USE."
+ fi
+}