summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-03-10 15:24:10 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-03-10 15:24:10 +0000
commit0ff8cb0d9639cd1ad6574a1f07f6be240c5ad116 (patch)
tree8b4edf1df936e842ea5907603889470cbd5bebcc /dev-php/PHPUnit_Selenium
parentMoving dev-php/phpunit-mockobject to dev-php/PHPUnit_MockObject (diff)
downloadgentoo-2-0ff8cb0d9639cd1ad6574a1f07f6be240c5ad116.tar.gz
gentoo-2-0ff8cb0d9639cd1ad6574a1f07f6be240c5ad116.tar.bz2
gentoo-2-0ff8cb0d9639cd1ad6574a1f07f6be240c5ad116.zip
Moving dev-php/phpunit-selenium to dev-php/PHPUnit_Selenium
(Portage version: 2.1.10.44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-php/PHPUnit_Selenium')
-rw-r--r--dev-php/PHPUnit_Selenium/ChangeLog24
-rw-r--r--dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.0.ebuild26
-rw-r--r--dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.1.ebuild26
-rw-r--r--dev-php/PHPUnit_Selenium/metadata.xml5
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-php/PHPUnit_Selenium/ChangeLog b/dev-php/PHPUnit_Selenium/ChangeLog
new file mode 100644
index 000000000000..48a467f4a578
--- /dev/null
+++ b/dev-php/PHPUnit_Selenium/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-php5/phpunit-selenium
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PHPUnit_Selenium/ChangeLog,v 1.1 2012/03/10 15:24:10 olemarkus Exp $
+
+ 24 May 2011; Markos Chandras <hwoarang@gentoo.org>
+ phpunit-selenium-1.0.1.ebuild:
+ Stable on amd64 wrt bug #368293
+
+ 23 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ phpunit-selenium-1.0.1.ebuild:
+ x86 stable wrt bug #368293
+
+*phpunit-selenium-1.0.1 (26 Mar 2011)
+
+ 26 Mar 2011; Ole Markus With <olemarkus@gentoo.org>
+ +phpunit-selenium-1.0.1.ebuild:
+ Version bump
+
+*phpunit-selenium-1.0.0 (04 Oct 2010)
+
+ 04 Oct 2010; Markus Ullmann <jokey@gentoo.org>
+ +phpunit-selenium-1.0.0.ebuild, +metadata.xml:
+ Initial import for phpunit-3.5
+
diff --git a/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.0.ebuild b/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.0.ebuild
new file mode 100644
index 000000000000..3eb0c3f9ef33
--- /dev/null
+++ b/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.0.ebuild,v 1.1 2012/03/10 15:24:10 olemarkus Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Selenium RC integration for PHPUnit"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit_Selenium-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-Testing_Selenium-0.2.0"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit_Selenium-${PV}"
diff --git a/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.1.ebuild b/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.1.ebuild
new file mode 100644
index 000000000000..6064641e7137
--- /dev/null
+++ b/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PHPUnit_Selenium/PHPUnit_Selenium-1.0.1.ebuild,v 1.1 2012/03/10 15:24:10 olemarkus Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="Selenium RC integration for PHPUnit"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit_Selenium-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-Testing_Selenium-0.2.0"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit_Selenium-${PV}"
diff --git a/dev-php/PHPUnit_Selenium/metadata.xml b/dev-php/PHPUnit_Selenium/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PHPUnit_Selenium/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>