summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-03-03 21:08:46 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-03-03 21:08:46 +0000
commit7bf6d9a855cad043c935a7e17fc53d1dbd972b35 (patch)
treebeeb6d7753527e2301f610344aa635ad3823f19f /dev-php/ZendFramework/ZendFramework-1.11.4.ebuild
parenthttp://my.opera.com/desktopteam/blog/2011/03/03/speed-dial-zooming-multi-colu... (diff)
downloadgentoo-2-7bf6d9a855cad043c935a7e17fc53d1dbd972b35.tar.gz
gentoo-2-7bf6d9a855cad043c935a7e17fc53d1dbd972b35.tar.bz2
gentoo-2-7bf6d9a855cad043c935a7e17fc53d1dbd972b35.zip
Version bump
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/ZendFramework/ZendFramework-1.11.4.ebuild')
-rw-r--r--dev-php/ZendFramework/ZendFramework-1.11.4.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-php/ZendFramework/ZendFramework-1.11.4.ebuild b/dev-php/ZendFramework/ZendFramework-1.11.4.ebuild
new file mode 100644
index 000000000000..6e97a06f232f
--- /dev/null
+++ b/dev-php/ZendFramework/ZendFramework-1.11.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ZendFramework/ZendFramework-1.11.4.ebuild,v 1.1 2011/03/03 21:08:46 olemarkus Exp $
+
+EAPI="2"
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples minimal cli"
+
+DEPEND="cli? ( dev-lang/php[simplexml,tokenizer] )"
+RDEPEND="${DEPEND}"
+need_php_by_category
+
+src_prepare() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ if use doc ; then
+ mv "${WORKDIR}/${P}/documentation" "${S}"
+ fi
+ fi
+}
+
+src_install() {
+ if use cli ; then
+ insinto /usr/bin
+ doins bin/zf.php
+ dobin bin/zf.sh
+ dosym /usr/bin/zf.sh /usr/bin/zf
+ fi
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if ! use minimal ; then
+ insinto /usr/share/php5
+ doins -r externals/dojo
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+
+ if ! use minimal ; then
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests have not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includes the Dojo toolkit, demos and tests."
+ elog "To install ZendFramework without these, enable the"
+ elog "minimal USE flag."
+ fi
+}