summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-10-02 11:32:51 +0000
committerPeter Volkov <pva@gentoo.org>2011-10-02 11:32:51 +0000
commit09d9698712fcbb561d2f79e2fce7216b0ede9ab3 (patch)
treee106ba10c1b866a1bb3fecffb26735a30a0df7c1 /dev-php/adodb/adodb-5.14.ebuild
parentRemoved versions affected by bug 384539 and cleaned out unused files. (diff)
downloadgentoo-2-09d9698712fcbb561d2f79e2fce7216b0ede9ab3.tar.gz
gentoo-2-09d9698712fcbb561d2f79e2fce7216b0ede9ab3.tar.bz2
gentoo-2-09d9698712fcbb561d2f79e2fce7216b0ede9ab3.zip
Version bump. Drop old.
(Portage version: 2.1.10.20/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/adodb/adodb-5.14.ebuild')
-rw-r--r--dev-php/adodb/adodb-5.14.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/adodb/adodb-5.14.ebuild b/dev-php/adodb/adodb-5.14.ebuild
new file mode 100644
index 000000000000..4d7f7dd73939
--- /dev/null
+++ b/dev-php/adodb/adodb-5.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/adodb/adodb-5.14.ebuild,v 1.1 2011/10/02 11:32:51 pva Exp $
+
+EAPI="2"
+
+inherit php-lib-r1 versionator
+
+MY_PV=$(delete_all_version_separators "${PV}" )
+DESCRIPTION="Active Data Objects Data Base library for PHP."
+HOMEPAGE="http://adodb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adodb/${PN}${MY_PV}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}$(get_major_version)
+
+need_php5
+
+pkg_setup() {
+ ewarn "ADODB requires some form of SQL or ODBC support in your PHP."
+}
+
+src_install() {
+ # install php files
+ php-lib-r1_src_install . $(find . -name '*.php' -print)
+
+ # install xsl files
+ php-lib-r1_src_install . xsl/*.xsl
+
+ # install documentation
+ dodoc-php *.txt xmlschema.dtd session/adodb-sess.txt pear/readme.Auth.txt
+ dohtml-php docs/*.htm
+}