summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-05 12:07:01 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-05 12:07:01 +0000
commitf79b862291277552ef4d2dae4eb6d89ae8e3f2f9 (patch)
tree30c938f4644ce10041182d39ecfe368201bdd05e /dev-php/phpgroupware
parentVersion bumped. Closes #23962. (diff)
downloadgentoo-2-f79b862291277552ef4d2dae4eb6d89ae8e3f2f9.tar.gz
gentoo-2-f79b862291277552ef4d2dae4eb6d89ae8e3f2f9.tar.bz2
gentoo-2-f79b862291277552ef4d2dae4eb6d89ae8e3f2f9.zip
Version bumped. Closes #23962.
Diffstat (limited to 'dev-php/phpgroupware')
-rw-r--r--dev-php/phpgroupware/ChangeLog8
-rw-r--r--dev-php/phpgroupware/Manifest4
-rw-r--r--dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.0041
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.004.ebuild49
4 files changed, 59 insertions, 3 deletions
diff --git a/dev-php/phpgroupware/ChangeLog b/dev-php/phpgroupware/ChangeLog
index 9648120ced7e..9b64932eff4f 100644
--- a/dev-php/phpgroupware/ChangeLog
+++ b/dev-php/phpgroupware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phpgroupware
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.6 2003/06/28 19:15:58 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.7 2003/07/05 12:06:35 mholzer Exp $
+
+*phpgroupware-0.9.14.004 (05 Jul 2003)
+
+ 05 Jul 2003; Martin Holzer <mholzer@gentoo.org>
+ phpgroupware-0.9.14.004.ebuild:
+ Version bumped. Closes #23962.
*phpgroupware-0.9.14.003 (28 Jun 2003)
diff --git a/dev-php/phpgroupware/Manifest b/dev-php/phpgroupware/Manifest
index 7c38562c4465..bf32b374dec0 100644
--- a/dev-php/phpgroupware/Manifest
+++ b/dev-php/phpgroupware/Manifest
@@ -1,5 +1,5 @@
-MD5 6d55781e2ee6c8d600be5cdc68b45326 ChangeLog 888
-MD5 9fe28e7e4ea46efdd81687f5f4249eb1 phpgroupware-0.9.14.004.ebuild 1417
+MD5 6d6b517c2440dde95d4430871e3d88e6 ChangeLog 1046
+MD5 d49d7006dcf63a7d073634dc5f76b558 phpgroupware-0.9.14.004.ebuild 1417
MD5 a35340887125c6ef78bdcea5747bf30a phpgroupware-0.9.14.003.ebuild 1427
MD5 f09757419b568534a24ed7d30babad11 files/digest-phpgroupware-0.9.14.004 77
MD5 c508961bd9ace9b7fe77bfc9381aecc9 files/digest-phpgroupware-0.9.14.003 77
diff --git a/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.004 b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.004
new file mode 100644
index 000000000000..7bd026d3ebce
--- /dev/null
+++ b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.004
@@ -0,0 +1 @@
+MD5 b4aae30c58dde01b7ae65b206df39249 phpgroupware-0.9.14.004.tar.bz2 6112889
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.004.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.004.ebuild
new file mode 100644
index 000000000000..d5ea32c3126f
--- /dev/null
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.004.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.004.ebuild,v 1.1 2003/07/05 12:06:35 mholzer Exp $
+
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="The phpGroupWare intranet/groupware tool and application framework."
+SRC_URI="mirror://sourceforge/phpgroupware/${P}.tar.bz2"
+HOMEPAGE="http://www.phpgroupware.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE=""
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/phpgroupware ] ; then
+ ewarn "You need to unmerge your old phpGroupWare version first."
+ ewarn "phpGroupWare will be installed into ${HTTPD_ROOT}/phpgroupware"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+ dodir ${HTTPD_ROOT}/phpgroupware
+ cd ${WORKDIR}
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} phpgroupware
+ chmod -R 700 phpgroupware/files
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at http://docs.phpgroupware.org/12-docs/html/admin/x62.html#AEN134 "
+ einfo "to complete the install. You need to add MySQL users and configure phpGroupWare"
+}