summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2014-01-06 17:26:14 +0000
committerMatti Bickel <mabi@gentoo.org>2014-01-06 17:26:14 +0000
commitdb34425949670199629d2374ced4bf825d1cb629 (patch)
treee07ddd0ed6a93356acc4026d643ea8533d59de5b /dev-php/phptal
parentAdd a bunch of random fixes from upstream which also fix ptrace headers #4802... (diff)
downloadgentoo-2-db34425949670199629d2374ced4bf825d1cb629.tar.gz
gentoo-2-db34425949670199629d2374ced4bf825d1cb629.tar.bz2
gentoo-2-db34425949670199629d2374ced4bf825d1cb629.zip
version bump, cleanup
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'dev-php/phptal')
-rw-r--r--dev-php/phptal/ChangeLog13
-rw-r--r--dev-php/phptal/phptal-1.2.1.ebuild33
-rw-r--r--dev-php/phptal/phptal-1.2.2.ebuild29
3 files changed, 38 insertions, 37 deletions
diff --git a/dev-php/phptal/ChangeLog b/dev-php/phptal/ChangeLog
index e10b91b71f75..148cea5c90f0 100644
--- a/dev-php/phptal/ChangeLog
+++ b/dev-php/phptal/ChangeLog
@@ -1,10 +1,15 @@
-# ChangeLog for dev-php5/phptal
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phptal/ChangeLog,v 1.1 2011/03/05 09:38:39 olemarkus Exp $
+# ChangeLog for dev-php/phptal
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phptal/ChangeLog,v 1.2 2014/01/06 17:26:14 mabi Exp $
+
+*phptal-1.2.2 (06 Jan 2014)
+
+ 06 Jan 2014; Matti Bickel <mabi@gentoo.org> +phptal-1.2.2.ebuild,
+ -phptal-1.2.1.ebuild:
+ version bump, cleanup
*phptal-1.2.1 (02 Jan 2010)
02 Jan 2010; Ben de Groot <yngwin@gentoo.org> +phptal-1.2.1.ebuild,
+metadata.xml:
Initial import. Ebuild by me.
-
diff --git a/dev-php/phptal/phptal-1.2.1.ebuild b/dev-php/phptal/phptal-1.2.1.ebuild
deleted file mode 100644
index f90f17700440..000000000000
--- a/dev-php/phptal/phptal-1.2.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phptal/phptal-1.2.1.ebuild,v 1.1 2011/03/05 09:38:39 olemarkus Exp $
-
-EAPI="2"
-inherit depend.php
-
-MY_P="PHPTAL-${PV}"
-DESCRIPTION="A templating engine for PHP5 that implements Zope Page Templates syntax"
-HOMEPAGE="http://phptal.org/"
-SRC_URI="http://phptal.org/files/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-need_php_by_category
-
-src_install() {
- has_php
-
- insinto /usr/share/php5/${PN}
- doins -r PHPTAL
- doins PHPTAL.php phptal_lint.php
-
- dodoc-php README
-}
diff --git a/dev-php/phptal/phptal-1.2.2.ebuild b/dev-php/phptal/phptal-1.2.2.ebuild
new file mode 100644
index 000000000000..c85c8f936843
--- /dev/null
+++ b/dev-php/phptal/phptal-1.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phptal/phptal-1.2.2.ebuild,v 1.1 2014/01/06 17:26:14 mabi Exp $
+
+EAPI=5
+
+PHP_LIB_NAME="PHPTAL"
+
+DESCRIPTION="A templating engine for PHP5 that implements Zope Page Templates syntax"
+HOMEPAGE="http://phptal.org/"
+SRC_URI="http://phptal.org/files/${PHP_LIB_NAME}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${PHP_LIB_NAME}-${PV}"
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ doins -r "${PHP_LIB_NAME}"
+ doins PHPTAL.php phptal_lint.php
+
+ dodoc README
+}