summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-03-28 10:35:54 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-03-28 10:35:54 +0000
commit257a3d6f20528bf3c1fe36457e5a2cbcfa3ef749 (patch)
treec10965fe1a1bcc08d3282bd6fb7be052ef80867c /dev-php/phpunit
parentClean up global vars in the ebuild. Sync the -r1 backport to the fresh ebuild... (diff)
downloadgentoo-2-257a3d6f20528bf3c1fe36457e5a2cbcfa3ef749.tar.gz
gentoo-2-257a3d6f20528bf3c1fe36457e5a2cbcfa3ef749.tar.bz2
gentoo-2-257a3d6f20528bf3c1fe36457e5a2cbcfa3ef749.zip
Bump. Changed to using a phar with all the bundled deps (which is only used by phpunit anyway)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/phpunit')
-rw-r--r--dev-php/phpunit/ChangeLog11
-rw-r--r--dev-php/phpunit/phpunit-3.7.19.ebuild38
2 files changed, 46 insertions, 3 deletions
diff --git a/dev-php/phpunit/ChangeLog b/dev-php/phpunit/ChangeLog
index e33635f83985..4413444015ca 100644
--- a/dev-php/phpunit/ChangeLog
+++ b/dev-php/phpunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phpunit
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.12 2012/06/22 17:44:32 mabi Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.13 2013/03/28 10:35:54 olemarkus Exp $
+
+*phpunit-3.7.19 (28 Mar 2013)
+
+ 28 Mar 2013; Ole Markus With <olemarkus@gentoo.org> +phpunit-3.7.19.ebuild:
+ Bump. Changed to using a phar with all the bundled deps (which is only used by
+ phpunit anyway)
*phpunit-3.6.11 (22 Jun 2012)
@@ -235,4 +241,3 @@
08 Sep 2006; Sebastian Bergmann <sebastian@gentoo.org> +metadata.xml,
+phpunit-2.3.6.ebuild:
Initial ebuild.
-
diff --git a/dev-php/phpunit/phpunit-3.7.19.ebuild b/dev-php/phpunit/phpunit-3.7.19.ebuild
new file mode 100644
index 000000000000..c14656c45713
--- /dev/null
+++ b/dev-php/phpunit/phpunit-3.7.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/phpunit-3.7.19.ebuild,v 1.1 2013/03/28 10:35:54 olemarkus Exp $
+
+EAPI=5
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+
+PHPUNIT_PHAR="${P}.phar"
+
+SRC_URI="http://dev.gentoo.org/~olemarkus/phpunit/${PHPUNIT_PHAR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/php[phar,xml]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/php/phpunit
+ insopts -m755
+ newins "${DISTDIR}"/${PHPUNIT_PHAR} phpunit.phar
+ dosym /usr/share/php/phpunit/phpunit.phar /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}