summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-08-25 08:22:22 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-08-25 08:22:22 +0000
commit802dee75d484e1f53468a08656b1e36ee4a85e35 (patch)
tree01b23a45d752de91de098d943908a124f9964899 /dev-php/suhosin
parentversion bump (diff)
downloadgentoo-2-802dee75d484e1f53468a08656b1e36ee4a85e35.tar.gz
gentoo-2-802dee75d484e1f53468a08656b1e36ee4a85e35.tar.bz2
gentoo-2-802dee75d484e1f53468a08656b1e36ee4a85e35.zip
Readding suhosin-0.9.33.ebuild. Was removed by a mistake
(Portage version: 2.1.11.9/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-php/suhosin')
-rw-r--r--dev-php/suhosin/ChangeLog7
-rw-r--r--dev-php/suhosin/suhosin-0.9.33.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-php/suhosin/ChangeLog b/dev-php/suhosin/ChangeLog
index 42f3ae314ed9..0be21d76615d 100644
--- a/dev-php/suhosin/ChangeLog
+++ b/dev-php/suhosin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/suhosin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/ChangeLog,v 1.10 2012/08/23 19:17:39 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/ChangeLog,v 1.11 2012/08/25 08:22:22 olemarkus Exp $
+
+*suhosin-0.9.33 (25 Aug 2012)
+
+ 25 Aug 2012; Ole Markus With <olemarkus@gentoo.org> +suhosin-0.9.33.ebuild:
+ Readding suhosin-0.9.33.ebuild. Was removed by a mistake
23 Aug 2012; Ole Markus With <olemarkus@gentoo.org> -suhosin-0.9.33.ebuild:
Removing old ebuilds
diff --git a/dev-php/suhosin/suhosin-0.9.33.ebuild b/dev-php/suhosin/suhosin-0.9.33.ebuild
new file mode 100644
index 000000000000..33b7c1f95caa
--- /dev/null
+++ b/dev-php/suhosin/suhosin-0.9.33.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/suhosin-0.9.33.ebuild,v 1.10 2012/08/25 08:22:22 olemarkus Exp $
+
+EAPI="2"
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r2
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 s390 sh sparc x86"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations."
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tgz"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/php[unicode]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}"/${P}-libcrypt.patch
+ epatch "${FILESDIR}"/${P}-fix-ZTS-compile-problem.patch
+ done
+ php-ext-source-r2_src_prepare
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc CREDITS
+
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+ done
+}
+
+src_test() {
+ # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
+ # away from there in src_compile
+ for slot in `php_get_slots`; do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}