summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-04 18:30:25 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-04 18:30:25 +0000
commit874bb757e38e75f150cda8d0f364b29d06aabae5 (patch)
tree6a5d3495075fc06d4e0f6d364f726707b650a1ef /dev-php4/pecl-sqlite
parentstable x86; bug 169212 (diff)
downloadgentoo-2-874bb757e38e75f150cda8d0f364b29d06aabae5.tar.gz
gentoo-2-874bb757e38e75f150cda8d0f364b29d06aabae5.tar.bz2
gentoo-2-874bb757e38e75f150cda8d0f364b29d06aabae5.zip
Use external libsqlite2.
(Portage version: 2.1.2-r13)
Diffstat (limited to 'dev-php4/pecl-sqlite')
-rw-r--r--dev-php4/pecl-sqlite/ChangeLog5
-rw-r--r--dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild15
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-php4/pecl-sqlite/ChangeLog b/dev-php4/pecl-sqlite/ChangeLog
index 01c6fad8b8c3..75d759bd72d6 100644
--- a/dev-php4/pecl-sqlite/ChangeLog
+++ b/dev-php4/pecl-sqlite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php4/pecl-sqlite
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-sqlite/ChangeLog,v 1.15 2007/02/09 02:55:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-sqlite/ChangeLog,v 1.16 2007/03/04 18:30:25 chtekk Exp $
+
+ 04 Mar 2007; Luca Longinotti <chtekk@gentoo.org> pecl-sqlite-1.0.3.ebuild:
+ Cleanup, use external libsqlite2 to avoid problems.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild b/dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild
index 80d47cdb3f30..8329dbf83d93 100644
--- a/dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild
+++ b/dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild,v 1.19 2006/01/26 20:06:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-sqlite/pecl-sqlite-1.0.3.ebuild,v 1.20 2007/03/04 18:30:25 chtekk Exp $
PHP_EXT_NAME="sqlite"
PHP_EXT_PECL_PKG="SQLite"
@@ -10,14 +10,19 @@ PHP_EXT_ZENDEXT="no"
inherit php-ext-pecl-r1
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+
DESCRIPTION="PHP bindings for the SQLite database engine."
LICENSE="PHP"
SLOT="0"
IUSE=""
+DEPEND="=dev-db/sqlite-2*"
+RDEPEND="${DEPEND}"
+
need_php_by_category
-src_install() {
- php-ext-pecl-r1_src_install
- dodoc-php README TODO
+src_compile() {
+ has_php
+ my_conf="--with-sqlite=/usr"
+ php-ext-pecl-r1_src_compile
}