summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-02-06 15:08:49 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-02-06 15:08:49 +0000
commit06ef1a30263279bea83b4231d0d0838a20f4e999 (patch)
tree1d6757e8892b77779931b6cb395639cf79c26b75 /dev-php4
parentInitial import. Ebuild first submitted by Ben Schwartz, see bug #170989 (diff)
downloadgentoo-2-06ef1a30263279bea83b4231d0d0838a20f4e999.tar.gz
gentoo-2-06ef1a30263279bea83b4231d0d0838a20f4e999.tar.bz2
gentoo-2-06ef1a30263279bea83b4231d0d0838a20f4e999.zip
untested bump to 0.9.23, bug 209070
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/suhosin/ChangeLog10
-rw-r--r--dev-php4/suhosin/suhosin-0.9.23.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-php4/suhosin/ChangeLog b/dev-php4/suhosin/ChangeLog
index fb2abbf977ff..d4a28efbe921 100644
--- a/dev-php4/suhosin/ChangeLog
+++ b/dev-php4/suhosin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/suhosin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/suhosin/ChangeLog,v 1.19 2007/12/04 11:11:00 hoffie Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/suhosin/ChangeLog,v 1.20 2008/02/06 15:08:49 hoffie Exp $
+
+*suhosin-0.9.23 (06 Feb 2008)
+
+ 06 Feb 2008; Christian Hoffmann <hoffie@gentoo.org>
+ +suhosin-0.9.23.ebuild:
+ untested bump to 0.9.23, bug 209070
*suhosin-0.9.22 (04 Dec 2007)
diff --git a/dev-php4/suhosin/suhosin-0.9.23.ebuild b/dev-php4/suhosin/suhosin-0.9.23.ebuild
new file mode 100644
index 000000000000..0e0682046d9a
--- /dev/null
+++ b/dev-php4/suhosin/suhosin-0.9.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/suhosin/suhosin-0.9.23.ebuild,v 1.1 2008/02/06 15:08:49 hoffie Exp $
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tgz"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use unicode
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php CREDITS
+
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+}