summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-03-19 20:22:44 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-03-19 20:22:44 +0000
commitf391744d1dc262d4e9f02da91be75e3693e8c7ab (patch)
tree7af4dabd5d756216e0d9bf8ee3d9fe8538b0536e /dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild
parentFix dbus deps so dbus-python is always there. Bug #171479 (diff)
downloadgentoo-2-f391744d1dc262d4e9f02da91be75e3693e8c7ab.tar.gz
gentoo-2-f391744d1dc262d4e9f02da91be75e3693e8c7ab.tar.bz2
gentoo-2-f391744d1dc262d4e9f02da91be75e3693e8c7ab.zip
* ZTS-related fixes
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild')
-rw-r--r--dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild b/dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..f3096407b9bb
--- /dev/null
+++ b/dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp-module/onphp-module-0.6.4-r1.ebuild,v 1.1 2007/03/19 20:22:44 voxus Exp $
+
+PHP_EXT_NAME="onphp"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+SRC_URI="http://onphp.org/download/onphp-${PV}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="onPHP's module."
+HOMEPAGE="http://onphp.org/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# since need_php51 is missing
+DEPEND=">=dev-lang/php-5.1.4"
+RDEPEND="${DEPEND}
+ ~dev-php5/onphp-${PV}"
+
+PHP_VERSION="5"
+PHP_SHARED_CAT="php5"
+
+S="${WORKDIR}/onphp-${PV}/ext"
+
+pkg_setup() {
+ has_php
+
+ require_php_with_use spl reflection
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch ${FILESDIR}/${PN}-r2861.patch
+}