summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2009-12-16 16:56:23 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2009-12-16 16:56:23 +0000
commit7fe07343fd7369f4c7bbcb6e7a5055cb6bb8650d (patch)
tree7290d06f5882e5f2a3fb772452fce89a847a8135 /dev-php5/pecl-fileinfo
parentalpha/ia64/m68k/s390/sh/sparc stable wrt #293863 (diff)
downloadgentoo-2-7fe07343fd7369f4c7bbcb6e7a5055cb6bb8650d.tar.gz
gentoo-2-7fe07343fd7369f4c7bbcb6e7a5055cb6bb8650d.tar.bz2
gentoo-2-7fe07343fd7369f4c7bbcb6e7a5055cb6bb8650d.zip
adding -r1 for >=file-5 compatibility per bug 288043, thanks to Cyril Pascal <cyril.pascal_gentoobugs@m4x.org>
(Portage version: 2.1.7.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-fileinfo')
-rw-r--r--dev-php5/pecl-fileinfo/ChangeLog12
-rw-r--r--dev-php5/pecl-fileinfo/files/fileinfo-1.0.4-file-5.0-compat.patch11
-rw-r--r--dev-php5/pecl-fileinfo/pecl-fileinfo-1.0.4-r1.ebuild28
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-php5/pecl-fileinfo/ChangeLog b/dev-php5/pecl-fileinfo/ChangeLog
index ef89de533865..4796dfab2f81 100644
--- a/dev-php5/pecl-fileinfo/ChangeLog
+++ b/dev-php5/pecl-fileinfo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-fileinfo
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-fileinfo/ChangeLog,v 1.22 2007/12/06 01:07:20 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-fileinfo/ChangeLog,v 1.23 2009/12/16 16:56:22 hoffie Exp $
+
+*pecl-fileinfo-1.0.4-r1 (16 Dec 2009)
+
+ 16 Dec 2009; Christian Hoffmann <hoffie@gentoo.org>
+ +pecl-fileinfo-1.0.4-r1.ebuild,
+ +files/fileinfo-1.0.4-file-5.0-compat.patch:
+ adding -r1 for >=file-5 compatibility per bug 288043, thanks to Cyril
+ Pascal <cyril.pascal_gentoobugs@m4x.org>
06 Dec 2007; Markus Ullmann <jokey@gentoo.org> pecl-fileinfo-1.0.4.ebuild:
LICENSE fix from project overlay
diff --git a/dev-php5/pecl-fileinfo/files/fileinfo-1.0.4-file-5.0-compat.patch b/dev-php5/pecl-fileinfo/files/fileinfo-1.0.4-file-5.0-compat.patch
new file mode 100644
index 000000000000..76e5616b6ca2
--- /dev/null
+++ b/dev-php5/pecl-fileinfo/files/fileinfo-1.0.4-file-5.0-compat.patch
@@ -0,0 +1,11 @@
+--- Fileinfo-1.0.4/config.m4.old 2009-10-16 19:45:10.000000000 +0200
++++ Fileinfo-1.0.4/config.m4 2009-10-16 19:45:24.000000000 +0200
+@@ -48,7 +48,7 @@
+ ])
+
+ MAGIC_MIME_DIRS="/usr/local/share/file /usr/share/file /usr/share/misc/file /etc /usr/share/misc"
+- MAGIC_MIME_FILENAMES="magic magic.mime"
++ MAGIC_MIME_FILENAMES="magic magic.mime magic.mgc"
+
+ for i in $MAGIC_MIME_DIRS; do
+ for j in $MAGIC_MIME_FILENAMES; do
diff --git a/dev-php5/pecl-fileinfo/pecl-fileinfo-1.0.4-r1.ebuild b/dev-php5/pecl-fileinfo/pecl-fileinfo-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..923eb0493773
--- /dev/null
+++ b/dev-php5/pecl-fileinfo/pecl-fileinfo-1.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-fileinfo/pecl-fileinfo-1.0.4-r1.ebuild,v 1.1 2009/12/16 16:56:22 hoffie Exp $
+
+PHP_EXT_NAME="fileinfo"
+PHP_EXT_PECL_PKG="Fileinfo"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="libmagic bindings for PHP."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-apps/file"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ PHP_EXT_SKIP_PHPIZE=yes php-ext-source-r1_src_unpack
+ epatch "${FILESDIR}"/fileinfo-1.0.4-file-5-compat.patch
+ php-ext-source-r1_phpize
+}
+
+need_php_by_category