summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-11-04 15:13:30 +0000
committerMatti Bickel <mabi@gentoo.org>2010-11-04 15:13:30 +0000
commitdd93fa66944d87c3d9ff3e7f246f37da83f41182 (patch)
tree5f0f26b04c873f737201a654d27838782348c4d6 /dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild
parentnew suacomp 0.6.6, EAPI bumped to correctly read 3 (prefix only anyway), remo... (diff)
downloadgentoo-2-dd93fa66944d87c3d9ff3e7f246f37da83f41182.tar.gz
gentoo-2-dd93fa66944d87c3d9ff3e7f246f37da83f41182.tar.bz2
gentoo-2-dd93fa66944d87c3d9ff3e7f246f37da83f41182.zip
add version supporting minor version slotting
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild')
-rw-r--r--dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild b/dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..cd221c44e92e
--- /dev/null
+++ b/dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-imagick/pecl-imagick-3.0.0-r1.ebuild,v 1.1 2010/11/04 15:13:30 mabi Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="imagick"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="TODO"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=media-gfx/imagemagick-6.2.4"
+RDEPEND="${DEPEND}"
+
+MY_PV="${PV/_/}"
+PECL_PKG_V="${PECL_PKG}-${MY_PV}"
+FILENAME="${PECL_PKG_V}.tgz"
+SRC_URI="http://pecl.php.net/get/${FILENAME}"
+S="${WORKDIR}/${PECL_PKG_V}"
+
+my_conf="--with-imagick=/usr"