summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-04 16:41:54 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-04 16:41:54 +0000
commit1ec27d2e0480fe9529ebb24eefb9da3cde104cb7 (patch)
treefc647e6f83358c2b49c975e15a1f55ea4cb9c0d7 /dev-php5/pecl-pdo-firebird
parentInitial import for PHP5 (diff)
downloadgentoo-2-1ec27d2e0480fe9529ebb24eefb9da3cde104cb7.tar.gz
gentoo-2-1ec27d2e0480fe9529ebb24eefb9da3cde104cb7.tar.bz2
gentoo-2-1ec27d2e0480fe9529ebb24eefb9da3cde104cb7.zip
Initial import for PHP5
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-php5/pecl-pdo-firebird')
-rw-r--r--dev-php5/pecl-pdo-firebird/ChangeLog7
-rw-r--r--dev-php5/pecl-pdo-firebird/Manifest4
-rw-r--r--dev-php5/pecl-pdo-firebird/files/digest-pecl-pdo-firebird-0.21
-rw-r--r--dev-php5/pecl-pdo-firebird/metadata.xml5
-rw-r--r--dev-php5/pecl-pdo-firebird/pecl-pdo-firebird-0.2.ebuild41
5 files changed, 58 insertions, 0 deletions
diff --git a/dev-php5/pecl-pdo-firebird/ChangeLog b/dev-php5/pecl-pdo-firebird/ChangeLog
new file mode 100644
index 000000000000..329371d7dcdb
--- /dev/null
+++ b/dev-php5/pecl-pdo-firebird/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-php5/pecl-pdo-firebird
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-firebird/ChangeLog,v 1.1 2005/09/04 16:38:01 stuart Exp $
+
+ 18 Aug 2005; <stuart@gentoo.org> ChangeLog:
+ Initial version; replaces older dev-php/* packages
+
diff --git a/dev-php5/pecl-pdo-firebird/Manifest b/dev-php5/pecl-pdo-firebird/Manifest
new file mode 100644
index 000000000000..ad505f0e32c6
--- /dev/null
+++ b/dev-php5/pecl-pdo-firebird/Manifest
@@ -0,0 +1,4 @@
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+MD5 73a6147926b04cb837b03c0ca6056ffa ChangeLog 227
+MD5 6261bb21a0802a46a8f2d1088e4c0a99 pecl-pdo-firebird-0.2.ebuild 938
+MD5 4a58f4edd1173f8f6332e928708f1137 files/digest-pecl-pdo-firebird-0.2 64
diff --git a/dev-php5/pecl-pdo-firebird/files/digest-pecl-pdo-firebird-0.2 b/dev-php5/pecl-pdo-firebird/files/digest-pecl-pdo-firebird-0.2
new file mode 100644
index 000000000000..b9307e83e873
--- /dev/null
+++ b/dev-php5/pecl-pdo-firebird/files/digest-pecl-pdo-firebird-0.2
@@ -0,0 +1 @@
+MD5 c716f713026cae6121b49ea56b954574 PDO_FIREBIRD-0.2.tgz 13380
diff --git a/dev-php5/pecl-pdo-firebird/metadata.xml b/dev-php5/pecl-pdo-firebird/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php5/pecl-pdo-firebird/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php5/pecl-pdo-firebird/pecl-pdo-firebird-0.2.ebuild b/dev-php5/pecl-pdo-firebird/pecl-pdo-firebird-0.2.ebuild
new file mode 100644
index 000000000000..7004ca10c773
--- /dev/null
+++ b/dev-php5/pecl-pdo-firebird/pecl-pdo-firebird-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-firebird/pecl-pdo-firebird-0.2.ebuild,v 1.1 2005/09/04 16:38:01 stuart Exp $
+
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_PKG="PDO_FIREBIRD"
+PHP_EXT_NAME="pdo_firebird"
+PHP_EXT_INI="yes"
+
+inherit php-ext-pecl-r1
+
+IUSE=""
+DESCRIPTION="PHP Data Objects (PDO) Driver For Firebird/Interbase Server"
+SLOT="0"
+LICENSE="PHP"
+KEYWORDS="~ppc ~x86"
+DEPEND="${DEPEND}
+ dev-php5/pecl-pdo
+ dev-db/firebird"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ # if the user has compiled in PDO, he can't use this package
+ if built_with_use =${PHP_PKG} pdo ; then
+ eerror
+ eerror "You have built ${PHP_PKG} to use the bundled PDO support."
+ eerror "If you want to use the PECL PDO packages, you must rebuild"
+ eerror "your PHP with the 'pdo-external' USE flag instead."
+ eerror
+ die "PHP built to use bundled PDO support"
+ fi
+}
+
+src_compile() {
+ has_php
+ my_conf="--with-pdo-firebird"
+ php-ext-pecl-r1_src_compile
+}