summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-04-16 14:01:53 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-04-16 14:01:53 +0000
commit162830e17956de9117d12b06c1f475975f058f11 (patch)
treeb26f659c7a69f645d76818db81e63fefd632b6b9 /dev-php5/phpdbg
parentRemoved older versions (diff)
downloadgentoo-2-162830e17956de9117d12b06c1f475975f058f11.tar.gz
gentoo-2-162830e17956de9117d12b06c1f475975f058f11.tar.bz2
gentoo-2-162830e17956de9117d12b06c1f475975f058f11.zip
Removed older versions
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/phpdbg')
-rw-r--r--dev-php5/phpdbg/ChangeLog6
-rw-r--r--dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild38
-rw-r--r--dev-php5/phpdbg/phpdbg-2.15.5.ebuild52
3 files changed, 43 insertions, 53 deletions
diff --git a/dev-php5/phpdbg/ChangeLog b/dev-php5/phpdbg/ChangeLog
index 519dafaaa72b..5489d3c6b96e 100644
--- a/dev-php5/phpdbg/ChangeLog
+++ b/dev-php5/phpdbg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/phpdbg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.17 2011/01/30 16:40:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.18 2011/04/16 14:01:51 olemarkus Exp $
+
+ 16 Apr 2011; <olemarkus@gentoo.org> -phpdbg-2.15.5.ebuild,
+ +phpdbg-2.15.5-r1.ebuild:
+ Removed the wrong version. Fixup.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> phpdbg-2.15.5.ebuild:
Drop sparc keywords
diff --git a/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild b/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild
new file mode 100644
index 000000000000..d45788bd4425
--- /dev/null
+++ b/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild,v 1.6 2011/04/16 14:01:51 olemarkus Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="dbg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-2"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+HOMEPAGE="http://dd.cron.ru/dbg/"
+SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}.tar.gz"
+LICENSE="dbgphp"
+SLOT="0"
+IUSE=""
+
+DEPEND="<dev-lang/php-5.3[-threads]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/dbg-${PV}"
+
+my_conf="--enable-dbg=shared --with-dbg-profiler"
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc-php AUTHORS COPYING INSTALL
+
+ php-ext-source-r2_addtoinifiles "[Debugger]"
+ php-ext-source-r2_addtoinifiles "debugger.enabled" "on"
+ php-ext-source-r2_addtoinifiles "debugger.profiler_enabled" "on"
+}
diff --git a/dev-php5/phpdbg/phpdbg-2.15.5.ebuild b/dev-php5/phpdbg/phpdbg-2.15.5.ebuild
deleted file mode 100644
index 35ec3ee5aad0..000000000000
--- a/dev-php5/phpdbg/phpdbg-2.15.5.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.15.5.ebuild,v 1.3 2011/01/30 16:40:37 armin76 Exp $
-
-PHP_EXT_NAME="dbg"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-DESCRIPTION="A PHP debugger useable with some editors like phpedit."
-HOMEPAGE="http://dd.cron.ru/dbg/"
-SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}.tar.gz"
-LICENSE="dbgphp"
-SLOT="0"
-IUSE=""
-
-DEPEND="<dev-lang/php-5.3"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/dbg-${PV}"
-
-need_php_by_category
-
-pkg_setup() {
- has_php
-
- # phpdbg does not work with Zend Thread Safety (ZTS),
- # so abort if we're using PHP compiled with ZTS.
- if has_zts ; then
- eerror "phpdbg doesn't work with a ZTS enabled PHP."
- eerror "Please disable ZTS by turning the 'threads'"
- eerror "USE flag off when you compile dev-lang/php."
- die "phpdbg does not support ZTS"
- fi
-}
-
-src_compile() {
- my_conf="--enable-dbg=shared --with-dbg-profiler"
- php-ext-source-r1_src_compile
-}
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php AUTHORS COPYING INSTALL
-
- php-ext-base-r1_addtoinifiles "[Debugger]"
- php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
- php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
-}