summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-10-08 19:58:06 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-10-08 19:58:06 +0000
commit27e128984637341a703b0eafe67059f511ece4cb (patch)
treef18a8f2f62a0125ce776895a47a6a38e8a7afc69 /dev-php5
parentClean up old revisions. (diff)
downloadgentoo-2-27e128984637341a703b0eafe67059f511ece4cb.tar.gz
gentoo-2-27e128984637341a703b0eafe67059f511ece4cb.tar.bz2
gentoo-2-27e128984637341a703b0eafe67059f511ece4cb.zip
Added version supporting minor version slotting
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/xdebug/ChangeLog7
-rw-r--r--dev-php5/xdebug/xdebug-2.1.0-r1.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/dev-php5/xdebug/ChangeLog b/dev-php5/xdebug/ChangeLog
index 7d31a24d5a6c..d8edced14fbb 100644
--- a/dev-php5/xdebug/ChangeLog
+++ b/dev-php5/xdebug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/xdebug
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.27 2010/08/08 15:26:47 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.28 2010/10/08 19:58:06 olemarkus Exp $
+
+*xdebug-2.1.0-r1 (08 Oct 2010)
+
+ 08 Oct 2010; <olemarkus@gentoo.org> +xdebug-2.1.0-r1.ebuild:
+ Added version supporting minor version slotting
*xdebug-2.1.0 (08 Aug 2010)
diff --git a/dev-php5/xdebug/xdebug-2.1.0-r1.ebuild b/dev-php5/xdebug/xdebug-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..0561ddae0397
--- /dev/null
+++ b/dev-php5/xdebug/xdebug-2.1.0-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/xdebug-2.1.0-r1.ebuild,v 1.1 2010/10/08 19:58:06 olemarkus Exp $
+
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+EAPI="2"
+inherit php-ext-source-r2
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DEPEND="!dev-php5/ZendOptimizer"
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc NEWS README Changelog CREDITS
+
+ php-ext-base-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-base-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-base-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-base-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.default_enable" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-base-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-base-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-base-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-base-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-base-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-base-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-base-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-base-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-base-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-base-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-base-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}