summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-10-08 19:45:08 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-10-08 19:45:08 +0000
commit77fb04b49a0239e6caf73976b0dcf0dd03fad050 (patch)
tree087d2d6fecf3b8bec08d8e0e403a0a04515f1478 /dev-php5
parentDropped ~ppc-macos, see you in prefix. (diff)
downloadgentoo-2-77fb04b49a0239e6caf73976b0dcf0dd03fad050.tar.gz
gentoo-2-77fb04b49a0239e6caf73976b0dcf0dd03fad050.tar.bz2
gentoo-2-77fb04b49a0239e6caf73976b0dcf0dd03fad050.zip
Fix for http://pecl.php.net/bugs/bug.php?id=5765. Patch by Lars Strojny <lars@strojny.net>.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-crack/ChangeLog7
-rw-r--r--dev-php5/pecl-crack/files/fix-pecl-bug-5765.patch11
-rw-r--r--dev-php5/pecl-crack/pecl-crack-0.4.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-php5/pecl-crack/ChangeLog b/dev-php5/pecl-crack/ChangeLog
index 74c7551778c0..9dc3c5daa2e3 100644
--- a/dev-php5/pecl-crack/ChangeLog
+++ b/dev-php5/pecl-crack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-crack
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-crack/ChangeLog,v 1.11 2006/09/29 07:17:33 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-crack/ChangeLog,v 1.12 2006/10/08 19:45:08 sebastian Exp $
+
+ 08 Oct 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ +files/fix-pecl-bug-5765.patch, pecl-crack-0.4.ebuild:
+ Fix for http://pecl.php.net/bugs/bug.php?id=5765. Patch by Lars Strojny
+ <lars@strojny.net>.
*pecl-crack-0.4 (29 Sep 2006)
diff --git a/dev-php5/pecl-crack/files/fix-pecl-bug-5765.patch b/dev-php5/pecl-crack/files/fix-pecl-bug-5765.patch
new file mode 100644
index 000000000000..c180d5310b1b
--- /dev/null
+++ b/dev-php5/pecl-crack/files/fix-pecl-bug-5765.patch
@@ -0,0 +1,11 @@
+--- crack-0.4/libcrack/src/cracklib.h 2005-09-21 11:00:06.000000000 +0200
++++ crack-0.4-new/libcrack/src/cracklib.h 2006-10-08 20:44:00.618783250 +0200
+@@ -46,7 +46,7 @@
+
+ typedef unsigned char int8;
+ typedef unsigned short int int16;
+-typedef unsigned long int int32;
++typedef unsigned int int32;
+
+ #ifndef NUMWORDS
+ # define NUMWORDS 16
diff --git a/dev-php5/pecl-crack/pecl-crack-0.4.ebuild b/dev-php5/pecl-crack/pecl-crack-0.4.ebuild
index 6b3e020e0b6e..1e88917fb590 100644
--- a/dev-php5/pecl-crack/pecl-crack-0.4.ebuild
+++ b/dev-php5/pecl-crack/pecl-crack-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-crack/pecl-crack-0.4.ebuild,v 1.1 2006/09/29 07:17:33 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-crack/pecl-crack-0.4.ebuild,v 1.2 2006/10/08 19:45:08 sebastian Exp $
PHP_EXT_NAME="crack"
PHP_EXT_INI="yes"
@@ -15,3 +15,11 @@ SLOT="0"
IUSE=""
need_php_by_category
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch for http://pecl.php.net/bugs/bug.php?id=5765
+ epatch "${FILESDIR}/fix-pecl-bug-5765.patch"
+}