summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-30 16:59:59 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-30 16:59:59 +0000
commit7d43c06ad7b3da7e304bf54a64a37aebd20fe00f (patch)
tree87ba1500df1e615abc97963b2eae5e5d3cb11f0a /dev-php5
parentVersion bump for 7.2. Build system fixes only. (diff)
downloadgentoo-2-7d43c06ad7b3da7e304bf54a64a37aebd20fe00f.tar.gz
gentoo-2-7d43c06ad7b3da7e304bf54a64a37aebd20fe00f.tar.bz2
gentoo-2-7d43c06ad7b3da7e304bf54a64a37aebd20fe00f.zip
* bump
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/xdebug/ChangeLog8
-rw-r--r--dev-php5/xdebug/files/digest-xdebug-2.0.0_rc23
-rw-r--r--dev-php5/xdebug/xdebug-2.0.0_rc2.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-php5/xdebug/ChangeLog b/dev-php5/xdebug/ChangeLog
index eee490262e13..151582db9256 100644
--- a/dev-php5/xdebug/ChangeLog
+++ b/dev-php5/xdebug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/xdebug
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.9 2006/10/27 19:02:30 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.10 2006/12/30 16:59:59 voxus Exp $
+
+*xdebug-2.0.0_rc2 (30 Dec 2006)
+
+ 30 Dec 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +xdebug-2.0.0_rc2.ebuild:
+ Version bump.
27 Oct 2006; Sebastian Bergmann <sebastian@gentoo.org>
xdebug-2.0.0_rc1.ebuild:
diff --git a/dev-php5/xdebug/files/digest-xdebug-2.0.0_rc2 b/dev-php5/xdebug/files/digest-xdebug-2.0.0_rc2
new file mode 100644
index 000000000000..0e4ca3911b75
--- /dev/null
+++ b/dev-php5/xdebug/files/digest-xdebug-2.0.0_rc2
@@ -0,0 +1,3 @@
+MD5 2abef81227a5d60af45ad0792e2fd996 xdebug-2.0.0rc2.tgz 259763
+RMD160 afc430bdca5394337b05cb685b4e6b990bfedbf0 xdebug-2.0.0rc2.tgz 259763
+SHA256 c0029fb444fc54d6b57cb85ff5a5ef415ef0fe6789fe89062e96cb16bca4f53b xdebug-2.0.0rc2.tgz 259763
diff --git a/dev-php5/xdebug/xdebug-2.0.0_rc2.ebuild b/dev-php5/xdebug/xdebug-2.0.0_rc2.ebuild
new file mode 100644
index 000000000000..c7b8287a0419
--- /dev/null
+++ b/dev-php5/xdebug/xdebug-2.0.0_rc2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/xdebug-2.0.0_rc2.ebuild,v 1.1 2006/12/30 16:59:59 voxus Exp $
+
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_NAME="xdebug"
+
+inherit php-ext-source-r1
+
+DESCRIPTION="A PHP Debugging and Profiling extension."
+HOMEPAGE="http://www.xdebug.org/"
+SLOT="0"
+MY_P="${P/_/}"
+SRC_URI="http://pecl.php.net/get/${MY_P}.tgz"
+S="${WORKDIR}/xdebug-2.0.0RC2"
+LICENSE="Xdebug"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="${RDEPEND}
+ !dev-php5/ZendOptimizer
+ dev-php/xdebug-client"
+
+need_php_by_category
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php NEWS README Changelog CREDITS LICENSE
+
+ php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"crc32"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"crc32"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.allowed_clients" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+}