summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-10-05 18:24:36 +0000
committerSteve Dibb <beandog@gentoo.org>2009-10-05 18:24:36 +0000
commit112f42513a8cddc155f9d5c11c38060b55a1c4dd (patch)
treee3a30ef389fe9c694ab36d7752b1120c2c0493b1 /dev-php
parentupdate metadata (diff)
downloadgentoo-2-112f42513a8cddc155f9d5c11c38060b55a1c4dd.tar.gz
gentoo-2-112f42513a8cddc155f9d5c11c38060b55a1c4dd.tar.bz2
gentoo-2-112f42513a8cddc155f9d5c11c38060b55a1c4dd.zip
Version bump
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog7
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.9.0.ebuild100
2 files changed, 106 insertions, 1 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index efdf17110776..e3035cca7818 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-PEAR
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.107 2009/09/23 02:41:50 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.108 2009/10/05 18:24:36 beandog Exp $
+
+*PEAR-PEAR-1.9.0 (05 Oct 2009)
+
+ 05 Oct 2009; Steve Dibb <beandog@gentoo.org> +PEAR-PEAR-1.9.0.ebuild:
+ Version bump
*PEAR-PEAR-1.8.1 (23 Sep 2009)
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.0.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.0.ebuild
new file mode 100644
index 000000000000..ec21df83a040
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.0.ebuild,v 1.1 2009/10/05 18:24:36 beandog Exp $
+
+inherit depend.php
+
+PEAR="${PV}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR Base System"
+HOMEPAGE="http://pear.php.net/package/PEAR"
+SRC_URI="http://pear.php.net/get/PEAR-${PEAR}.tgz"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/php"
+PDEPEND="=dev-php/pear-${PV}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ has_php
+
+ # we check that PHP was compiled with the correct USE flags
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli pcre expat zlib
+ else
+ require_php_with_use cli pcre xml zlib
+ fi
+
+ [[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
+ [[ -z "${PEAR_DOWNLOADDIR}" ]] && PEAR_DOWNLOADDIR="/var/tmp/pear"
+ [[ -z "${PEAR_TEMPDIR}" ]] && PEAR_TEMPDIR="/tmp"
+
+ elog
+ elog "cache_dir is set to: ${PEAR_CACHEDIR}"
+ elog "download_dir is set to: ${PEAR_DOWNLOADDIR}"
+ elog "temp_dir is set to: ${PEAR_TEMPDIR}"
+ elog
+ elog "If you want to change the above values, you need to set"
+ elog "PEAR_CACHEDIR, PEAR_DOWNLOADDIR and PEAR_TEMPDIR variable(s)"
+ elog "accordingly in /etc/make.conf and re-emerge ${PN}."
+ elog
+}
+
+src_install() {
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ # install PEAR package
+ cd "${S}"/PEAR-${PEAR}
+
+ insinto /usr/share/php
+ doins -r PEAR/
+ doins -r OS/
+ doins PEAR.php PEAR5.php System.php
+ doins scripts/pearcmd.php
+ doins scripts/peclcmd.php
+
+ newbin scripts/pear.sh pear
+ newbin scripts/peardev.sh peardev
+ newbin scripts/pecl.sh pecl
+
+ # adjust some scripts for current version
+ for i in pearcmd.php peclcmd.php ; do
+ dosed "s:@pear_version@:${PEAR}:g" /usr/share/php/${i}
+ done
+
+ for i in pear peardev pecl ; do
+ dosed "s:@php_bin@:${PHPCLI}:g" /usr/bin/${i}
+ dosed "s:@bin_dir@:/usr/bin:g" /usr/bin/${i}
+ dosed "s:@php_dir@:/usr/share/php:g" /usr/bin/${i}
+ done
+ dosed "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" /usr/bin/pear
+
+ dosed "s:@package_version@:${PEAR}:g" /usr/share/php/PEAR/Command/Package.php
+ dosed "s:@PEAR-VER@:${PEAR}:g" /usr/share/php/PEAR/Dependency2.php
+ dosed "s:@PEAR-VER@:${PEAR}:g" /usr/share/php/PEAR/PackageFile/Parser/v1.php
+ dosed "s:@PEAR-VER@:${PEAR}:g" /usr/share/php/PEAR/PackageFile/Parser/v2.php
+
+ # finalize install
+ insinto /etc
+ newins "${FILESDIR}"/pear.conf-r1 pear.conf
+ dosed "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" /etc/pear.conf
+ dosed "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" /etc/pear.conf
+ dosed "s|s:DOWNLOADDIRLEN:\"DOWNLOADDIR\"|s:${#PEAR_DOWNLOADDIR}:\"${PEAR_DOWNLOADDIR}\"|g" /etc/pear.conf
+ dosed "s|s:TEMPDIRLEN:\"TEMPDIR\"|s:${#PEAR_TEMPDIR}:\"${PEAR_TEMPDIR}\"|g" /etc/pear.conf
+
+ [[ "${PEAR_TEMPDIR}" != "/tmp" ]] && keepdir "${PEAR_TEMPDIR}"
+ keepdir "${PEAR_CACHEDIR}"
+ diropts -m1777
+ keepdir "${PEAR_DOWNLOADDIR}"
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}/etc/pear.conf"
+}