summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2004-12-17 02:28:01 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2004-12-17 02:28:01 +0000
commit33d0b998f2e49de8563fa6d8d6476ac11f649e32 (patch)
treedf0e0055f5d177486acd165c15e800f33c676714 /dev-php
parentSTable on sparc wrt #74547, solves #74627 (Manifest recommit) (diff)
downloadgentoo-2-33d0b998f2e49de8563fa6d8d6476ac11f649e32.tar.gz
gentoo-2-33d0b998f2e49de8563fa6d8d6476ac11f649e32.tar.bz2
gentoo-2-33d0b998f2e49de8563fa6d8d6476ac11f649e32.zip
Stable on sparc wrt #74547, solves #74627
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php-cgi/ChangeLog6
-rw-r--r--dev-php/php-cgi/files/stdint.diff11
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.10.ebuild7
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-php/php-cgi/ChangeLog b/dev-php/php-cgi/ChangeLog
index 5d180ce46a8f..82566df514f7 100644
--- a/dev-php/php-cgi/ChangeLog
+++ b/dev-php/php-cgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php-cgi
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.45 2004/12/16 10:52:15 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.46 2004/12/17 02:28:01 gustavoz Exp $
+
+ 16 Dec 2004; Gustavo Zacarias <gustavoz@gentoo.org> +files/stdint.diff,
+ php-cgi-4.3.10.ebuild:
+ Stable on sparc wrt #74547, solves #74627
16 Dec 2004; Dylan Carlson <absinthe@gentoo.org> php-cgi-4.3.10.ebuild:
Keywords ~amd64.
diff --git a/dev-php/php-cgi/files/stdint.diff b/dev-php/php-cgi/files/stdint.diff
new file mode 100644
index 000000000000..451d7fb44cf3
--- /dev/null
+++ b/dev-php/php-cgi/files/stdint.diff
@@ -0,0 +1,11 @@
+diff -Nura php-4.3.10/Zend/zend_strtod.c php-4.3.10.stdint/Zend/zend_strtod.c
+--- php-4.3.10/Zend/zend_strtod.c 2004-12-14 05:35:26.000000000 -0300
++++ php-4.3.10.stdint/Zend/zend_strtod.c 2004-12-16 15:33:47.000000000 -0300
+@@ -128,6 +128,7 @@
+ #endif
+
+ #if defined(__sparc__) || defined(__ppc__)
++#include <stdint.h>
+ #define u_int32_t uint32_t
+ #endif
+
diff --git a/dev-php/php-cgi/php-cgi-4.3.10.ebuild b/dev-php/php-cgi/php-cgi-4.3.10.ebuild
index 5d26bed86602..b500bc3cd336 100644
--- a/dev-php/php-cgi/php-cgi-4.3.10.ebuild
+++ b/dev-php/php-cgi/php-cgi-4.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.10.ebuild,v 1.2 2004/12/16 10:52:15 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.10.ebuild,v 1.3 2004/12/17 02:28:01 gustavoz Exp $
PHPSAPI="cgi"
inherit php-sapi eutils
@@ -13,6 +13,11 @@ KEYWORDS="x86 ~sparc ~alpha ~hppa ~ppc ~ia64 ~amd64"
PDEPEND=">=${PHP_PROVIDER_PKG}-4.3.10"
PROVIDE="${PROVIDE} virtual/httpd-php-${PV}"
+src_unpack() {
+ php-sapi_src_unpack
+ [ "${ARCH}" == "sparc" ] && epatch ${FILESDIR}/stdint.diff
+}
+
src_compile() {
# CLI needed to build stuff
myconf="${myconf} \