summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-18 15:42:03 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-18 15:42:03 +0000
commit56dc55167d2d03dd0834b2cde55e96c855aad3b5 (patch)
tree3aa84853d7b730e2a80c5bba085257d72ef36bc7 /dev-php
parentAdd net-im/aim-transport to p.mask for removal by treecleaners too (diff)
downloadgentoo-2-56dc55167d2d03dd0834b2cde55e96c855aad3b5.tar.gz
gentoo-2-56dc55167d2d03dd0834b2cde55e96c855aad3b5.tar.bz2
gentoo-2-56dc55167d2d03dd0834b2cde55e96c855aad3b5.zip
Cleanup.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog6
-rw-r--r--dev-php/smarty/files/digest-smarty-2.6.163
-rw-r--r--dev-php/smarty/smarty-2.6.14.ebuild15
-rw-r--r--dev-php/smarty/smarty-2.6.16.ebuild41
-rw-r--r--dev-php/smarty/smarty-2.6.18.ebuild41
5 files changed, 38 insertions, 68 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 8e860bb9ebac..1aff7bec2d10 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/smarty
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.68 2007/03/11 22:20:50 tomk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.69 2007/03/18 15:42:03 chtekk Exp $
+
+ 18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> smarty-2.6.14.ebuild,
+ -smarty-2.6.16.ebuild, smarty-2.6.18.ebuild:
+ Cleanup.
*smarty-2.6.18 (11 Mar 2007)
diff --git a/dev-php/smarty/files/digest-smarty-2.6.16 b/dev-php/smarty/files/digest-smarty-2.6.16
deleted file mode 100644
index 5a14cf2d42f9..000000000000
--- a/dev-php/smarty/files/digest-smarty-2.6.16
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 da67591f19b69a932c1cab7df5b0303a Smarty-2.6.16.tar.gz 151978
-RMD160 d2b66cd9094531fe44c582a37951ea86237defb9 Smarty-2.6.16.tar.gz 151978
-SHA256 1cd3a9c35f47142d685cc1c74129525fe8c54bd92a21023de9c6c120b4374b11 Smarty-2.6.16.tar.gz 151978
diff --git a/dev-php/smarty/smarty-2.6.14.ebuild b/dev-php/smarty/smarty-2.6.14.ebuild
index 6dfc1793bccb..60eb51bdc857 100644
--- a/dev-php/smarty/smarty-2.6.14.ebuild
+++ b/dev-php/smarty/smarty-2.6.14.ebuild
@@ -1,26 +1,31 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.14.ebuild,v 1.9 2007/01/28 06:27:38 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.14.ebuild,v 1.10 2007/03/18 15:42:03 chtekk Exp $
inherit php-lib-r1
+KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86"
+
+MY_P="Smarty-${PV}"
+
DESCRIPTION="A template engine for PHP."
HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86"
IUSE="doc"
-DEPEND="doc? ( dev-php/smarty-docs )"
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( dev-php/smarty-docs )"
-MY_P="Smarty-${PV}"
-SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
need_php_by_category
src_install() {
dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
}
diff --git a/dev-php/smarty/smarty-2.6.16.ebuild b/dev-php/smarty/smarty-2.6.16.ebuild
deleted file mode 100644
index 6a8b70d2e6bd..000000000000
--- a/dev-php/smarty/smarty-2.6.16.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.16.ebuild,v 1.2 2007/01/28 06:27:38 genone Exp $
-
-inherit php-lib-r1
-
-DESCRIPTION="A template engine for PHP."
-HOMEPAGE="http://smarty.php.net/"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-DEPEND="doc? ( dev-php/smarty-docs )"
-
-MY_P="Smarty-${PV}"
-SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-need_php_by_category
-
-src_install() {
- dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
- php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
-}
-
-pkg_postinst() {
- elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
- elog "To use it in your scripts, either"
- elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
- elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
- elog "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
- elog "cgi-php[45] or cli-php[45])."
- elog
- elog "If you're upgrading from a previous version make sure to clear out your"
- elog "templates_c and cache directories as some include paths have changed!"
- elog
- elog "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
- elog "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
- elog "include_path accordingly."
-}
diff --git a/dev-php/smarty/smarty-2.6.18.ebuild b/dev-php/smarty/smarty-2.6.18.ebuild
index 687afb6f2f03..c32b660c1286 100644
--- a/dev-php/smarty/smarty-2.6.18.ebuild
+++ b/dev-php/smarty/smarty-2.6.18.ebuild
@@ -1,41 +1,46 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.18.ebuild,v 1.1 2007/03/11 22:20:50 tomk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.18.ebuild,v 1.2 2007/03/18 15:42:03 chtekk Exp $
inherit php-lib-r1
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
DESCRIPTION="A template engine for PHP."
HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
-DEPEND="doc? ( dev-php/smarty-docs )"
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( dev-php/smarty-docs )"
-MY_P="Smarty-${PV}"
-SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
need_php_by_category
src_install() {
dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
}
pkg_postinst() {
- einfo "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
- einfo "To use it in your scripts, either"
- einfo "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
- einfo "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
- einfo "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
- einfo "cgi-php[45] or cli-php[45])."
- echo
- einfo "If you're upgrading from a previous version make sure to clear out your"
- einfo "templates_c and cache directories as some include paths have changed!"
- echo
- einfo "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
- einfo "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
- einfo "include_path accordingly."
+ elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+ elog "cgi-php[45] or cli-php[45])."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+ elog
+ elog "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
+ elog "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
+ elog "include_path accordingly."
}