summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-06-10 19:58:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-06-10 19:58:11 +0000
commit78d39ea156b726672ea90dad018c50833c7c4bae (patch)
tree499562f509ab35ab42db5df0222ab286e69532d8 /dev-php
parentMore combined apache fixes (diff)
downloadgentoo-2-78d39ea156b726672ea90dad018c50833c7c4bae.tar.gz
gentoo-2-78d39ea156b726672ea90dad018c50833c7c4bae.tar.bz2
gentoo-2-78d39ea156b726672ea90dad018c50833c7c4bae.zip
More combined apache fixes
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog12
-rw-r--r--dev-php/mod_php/Manifest5
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.2-r21
-rw-r--r--dev-php/mod_php/mod_php-4.3.2-r2.ebuild113
4 files changed, 127 insertions, 4 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 013821eca650..257755334a3f 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.81 2003/06/10 19:14:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.82 2003/06/10 19:58:08 robbat2 Exp $
+
+*mod_php-4.3.2-r2 (10 June 2003)
+
+ 10 June 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.2.ebuild:
+ This is an extension of the fixes in 4.3.2-r1, but I'm uncertain if some of
+ this magic is valid, so it is in a sepearate ebulid for now.
+ A special note on the change of behavior depending on the Apache(s) you have installed:
+ Apache1 ONLY: uses apache1 version
+ Apache2 ONLY: uses apache2 version (no USE="apache2" needed)
+ Apache1 AND Apache2: Use apache1 version unless the USE flag is in place.
*mod_php-4.3.2-r1 (10 June 2003)
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index 9c133c52e913..9ae738024b4d 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,13 +1,12 @@
MD5 136c8a948544ac163e93e4c45e46092c mod_php-4.3.2.ebuild 2740
MD5 31e28f7f7df06e387c40cdad216265ab mod_php-4.3.1-r3.ebuild 2589
-MD5 e02101c497ffb6abb910112b51ee1e8c mod_php-4.3.2-r2.ebuild 3086
+MD5 1850fcf46291e3a4926495f6f2211bfe mod_php-4.3.2-r2.ebuild 3086
MD5 a00cd3eced04951a9aa6a5d38bd7f6b6 mod_php-4.3.1.ebuild 9225
-MD5 e02101c497ffb6abb910112b51ee1e8c mod_php-4.3.2-r2.ebuild~ 3086
MD5 c99a00bf82ec9a082399ab1dd931c415 mod_php-4.3.1-r2.ebuild 9241
MD5 171b138769aa006ffa4393144555cba3 mod_php-4.3.2-r1.ebuild 2676
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
MD5 dfc6bd16160024127fa9b0c242fc8ab5 mod_php-4.3.0-r2.ebuild 8634
-MD5 ff9a6e7f019d6dac9c127f55270db8b5 ChangeLog 17166
+MD5 43e7f8da56589b596fb11c5df79d739b ChangeLog 17684
MD5 c585d6d5154fe64839f25db957301433 mod_php-4.3.1-r1.ebuild 9135
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 77023a54f39bae40733118d5cabd8f7f files/70_mod_php.conf 853
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.2-r2 b/dev-php/mod_php/files/digest-mod_php-4.3.2-r2
new file mode 100644
index 000000000000..8271dab4f822
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.2-r2
@@ -0,0 +1 @@
+MD5 8aec1bb2dbcca1c92835c71e2e30d9c5 php-4.3.2.tar.bz2 3697581
diff --git a/dev-php/mod_php/mod_php-4.3.2-r2.ebuild b/dev-php/mod_php/mod_php-4.3.2-r2.ebuild
new file mode 100644
index 000000000000..35bfb12f6a3f
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.2-r2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r2.ebuild,v 1.1 2003/06/10 19:58:08 robbat2 Exp $
+
+inherit php eutils
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~arm ~sparc"
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+
+DEPEND="${DEPEND}
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 ) "
+
+HAVE_APACHE1=
+HAVE_APACHE2=
+has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+[ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+[ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+[ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+case "${APACHEVER}" in
+ 1) break ;;
+ 2) break ;;
+ both) use apache2 && APACHEVER=2 || APACHEVER=1 ;;
+ *) MSG="Unknown Apache version!"; eerror $MSG ; die $MSG ;;
+esac
+
+SLOT="${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|prechild|leader|threadpool|prefork'|xargs|cut -d. -f1`"
+ case "${APACHE2_MPM}" in
+ prefork) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ;;
+ esac;
+ fi
+
+ # optional support for apache2
+ #&& myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ #|| myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+
+ #use apache2 \
+ myconf="${myconf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ #php CGI stuff
+ #--enable-discard-path --enable-force-cgi-redirect
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+
+ cp php.ini-dist php.ini
+ insinto /etc/php4
+ doins php.ini
+ dosym /etc/php4/php.ini /etc/apache${USE_APACHE2}/conf/php.ini
+
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules /etc/php4/lib
+ exeinto /usr/lib/apache${USE_APACHE2}-extramodules
+ doexe .libs/libphp4.so
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ else
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache/conf/addon-modules/php.ini
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP\""
+}
+
+pkg_postinst() {
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ if [ -n "${USE_APACHE2}" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}