summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-21 04:32:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-21 04:32:28 +0000
commitf0ce39d13e9d74a899da87d04c8e87993d8a5866 (patch)
treed9020609dd87b96d5d54c1e038d87ed8c58ae2be /dev-python/Babel
parentDrop mudflap from default USE. (diff)
downloadgentoo-2-f0ce39d13e9d74a899da87d04c8e87993d8a5866.tar.gz
gentoo-2-f0ce39d13e9d74a899da87d04c8e87993d8a5866.tar.bz2
gentoo-2-f0ce39d13e9d74a899da87d04c8e87993d8a5866.zip
Remove old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-0.9.6-r1.ebuild40
-rw-r--r--dev-python/Babel/Babel-1.2.ebuild48
-rw-r--r--dev-python/Babel/ChangeLog6
3 files changed, 5 insertions, 89 deletions
diff --git a/dev-python/Babel/Babel-0.9.6-r1.ebuild b/dev-python/Babel/Babel-0.9.6-r1.ebuild
deleted file mode 100644
index a276b298b54e..000000000000
--- a/dev-python/Babel/Babel-0.9.6-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/Babel-0.9.6-r1.ebuild,v 1.4 2013/09/05 18:46:16 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
-inherit distutils-r1
-
-DESCRIPTION="A collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ http://pypi.python.org/pypi/Babel"
-SRC_URI="http://ftp.edgewall.com/pub/babel/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
-
-DEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-HTML_DOCS=( doc/. )
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i babel/messages/tests/frontend.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l babel/messages/tests/data "${BUILD_DIR}"/ || die
-
- export BUILD_DIR
- esetup.py test
-}
diff --git a/dev-python/Babel/Babel-1.2.ebuild b/dev-python/Babel/Babel-1.2.ebuild
deleted file mode 100644
index 2e0ac5b4a2a2..000000000000
--- a/dev-python/Babel/Babel-1.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/Babel-1.2.ebuild,v 1.4 2013/09/05 18:46:16 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy2_0 )
-inherit distutils-r1
-
-DESCRIPTION="A collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ http://pypi.python.org/pypi/Babel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.3.5 )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- export BUILD_DIR
- py.test
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/ChangeLog b/dev-python/Babel/ChangeLog
index 28d62f8a9362..0d5875f1b0ee 100644
--- a/dev-python/Babel/ChangeLog
+++ b/dev-python/Babel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/Babel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/ChangeLog,v 1.61 2014/01/18 19:55:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/ChangeLog,v 1.62 2014/01/21 04:32:28 patrick Exp $
+
+ 21 Jan 2014; Patrick Lauer <patrick@gentoo.org> -Babel-0.9.6-r1.ebuild,
+ -Babel-1.2.ebuild:
+ Remove old
18 Jan 2014; Agostino Sarubbo <ago@gentoo.org> Babel-1.3.ebuild:
Stable for alpha, wrt bug #490382