summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-12 07:25:10 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-12 07:25:10 +0000
commit279620785839e6f6889326a4eb4515788233f9e7 (patch)
tree60c5d5f757fcc4a43cc8bdb823d5b123b582815d /dev-python/PyAmanith/PyAmanith-0.3.34.ebuild
parentRemove old version. (diff)
downloadgentoo-2-279620785839e6f6889326a4eb4515788233f9e7.tar.gz
gentoo-2-279620785839e6f6889326a4eb4515788233f9e7.tar.bz2
gentoo-2-279620785839e6f6889326a4eb4515788233f9e7.zip
Use NEED_PYTHON to depend on python. Use distutils_src_unpack. swig is not a runtime dependency, bug 221467.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-python/PyAmanith/PyAmanith-0.3.34.ebuild')
-rw-r--r--dev-python/PyAmanith/PyAmanith-0.3.34.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild b/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild
index 18ca0865f65d..b6d31f7db0bd 100644
--- a/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild
+++ b/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild,v 1.2 2006/10/13 17:03:03 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild,v 1.3 2008/05/12 07:25:10 hawking Exp $
+
+NEED_PYTHON=2.3
inherit eutils distutils
@@ -13,13 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-lang/python-2.3
- >=media-libs/amanith-0.3
+RDEPEND=">=media-libs/amanith-0.3"
+DEPEND="${RDEPEND}
>=dev-lang/swig-1.3.29"
src_unpack() {
- unpack ${A}
- cd "${S}"
+ distutils_src_unpack
+
# perhaps someone with more swig/distutils clout can make this
# package stop sucking so hard
sed -i \