summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-29 00:07:59 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-29 00:07:59 +0000
commit2111a16d7801c2e33978a919a6359ed5c564de7a (patch)
treefe211a4f1fa2fcf291c105da05b8bbca8313cbd4 /dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild
parentBump. (diff)
downloadgentoo-2-2111a16d7801c2e33978a919a6359ed5c564de7a.tar.gz
gentoo-2-2111a16d7801c2e33978a919a6359ed5c564de7a.tar.bz2
gentoo-2-2111a16d7801c2e33978a919a6359ed5c564de7a.zip
revbump; convert -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild')
-rw-r--r--dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild b/dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild
new file mode 100644
index 000000000000..d8828a89e346
--- /dev/null
+++ b/dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyFoam/PyFoam-0.5.4-r2.ebuild,v 1.1 2014/12/29 00:07:59 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to analyze and plot the residual files of OpenFOAM computations"
+HOMEPAGE="http://openfoamwiki.net/index.php/Contrib_PyFoam"
+SRC_URI="http://openfoamwiki.net/images/a/ae/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras"
+
+DEPEND="sci-visualization/gnuplot
+ || ( sci-libs/openfoam sci-libs/openfoam-bin )
+ extras? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ sci-libs/vtk[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${DEPEND}"