summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 18:45:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 18:45:33 +0000
commit6830ed6e02fb8578aefb6aa38a9d52daf088066a (patch)
tree82abad162da2833db796cfda8de360b9396e6030 /dev-python/PyQt4
parentUse PYTHON() instead of get_python(). (diff)
downloadgentoo-2-6830ed6e02fb8578aefb6aa38a9d52daf088066a.tar.gz
gentoo-2-6830ed6e02fb8578aefb6aa38a9d52daf088066a.tar.bz2
gentoo-2-6830ed6e02fb8578aefb6aa38a9d52daf088066a.zip
Use PYTHON() instead of get_python(). Use ${BUILDDIR}.
(Portage version: 13919-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/PyQt4/PyQt4-4.5.4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
index b14d61fc8aeb..cd42dc336484 100644
--- a/dev-python/PyQt4/PyQt4-4.5.4.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4.ebuild,v 1.6 2009/08/04 07:32:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4.ebuild,v 1.7 2009/08/05 18:45:33 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -71,7 +71,7 @@ src_prepare() {
src_configure() {
configuration() {
- local myconf="$(get_python) configure.py
+ local myconf="$(PYTHON) configure.py
--confirm-license
--bindir=/usr/bin
--destdir=$(python_get_sitedir)
@@ -97,7 +97,7 @@ src_configure() {
# Fix insecure runpath.
for pkg in QtCore $(use X && echo "QtDesigner QtGui"); do
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${S}-${PYTHON_ABI}/qpy/${pkg}::" ${pkg}/Makefile || die "failed to fix rpath issues"
+ sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${pkg}::" ${pkg}/Makefile || die "Failed to fix rpath issues"
done
}
python_execute_function -s configuration