summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-08-15 13:05:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-08-15 13:05:29 +0000
commit8442c9712753f4cfb9e90260ca52bd5f9b96967c (patch)
tree7d2baa970b59019a6ca7e4749111b54156d3716e /dev-python/PyQt4
parentUSE deps instead of built_with_use (diff)
downloadgentoo-2-8442c9712753f4cfb9e90260ca52bd5f9b96967c.tar.gz
gentoo-2-8442c9712753f4cfb9e90260ca52bd5f9b96967c.tar.bz2
gentoo-2-8442c9712753f4cfb9e90260ca52bd5f9b96967c.zip
Build QtScriptTools bindings. Fixes bug 279945
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog8
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild155
2 files changed, 162 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 2e763096ef80..c555814e32fa 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.81 2009/08/12 08:58:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.82 2009/08/15 13:05:29 hwoarang Exp $
+
+*PyQt4-4.5.4-r4 (15 Aug 2009)
+
+ 15 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r4.ebuild:
+ Build QtScriptTools bindings. Fixes bug 279945. Thanks to Davide Pesavento
+ <davidepesa@gmail.com> for the patch
*PyQt4-4.5.4-r3 (12 Aug 2009)
diff --git a/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
new file mode 100644
index 000000000000..81b57e6cd1d2
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild,v 1.1 2009/08/15 13:05:29 hwoarang Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python qt4 toolchain-funcs
+
+MY_P=PyQt-x11-gpl-${PV}
+QTVER="4.5.1"
+
+DESCRIPTION="A set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
+
+DEPEND=">=dev-python/sip-4.8.2
+ >=x11-libs/qt-core-${QTVER}:4
+ >=x11-libs/qt-script-${QTVER}:4
+ >=x11-libs/qt-test-${QTVER}:4
+ X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
+ assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
+ dbus? (
+ >=dev-python/dbus-python-0.80
+ >=x11-libs/qt-dbus-${QTVER}:4
+ )
+ opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
+ phonon? (
+ !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
+ kde? ( media-sound/phonon )
+ )
+ sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
+ svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
+ webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
+ xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/configure.py.patch"
+ # Remember to remove this patch since it is already on PyQt4-4.6
+ "${FILESDIR}/${P}-qgraphicslinearlayout-fix.patch"
+)
+
+src_prepare() {
+ if ! use dbus; then
+ sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
+ "${S}"/configure.py || die
+ fi
+ qt4_src_prepare
+
+ python_copy_sources
+
+ preparation() {
+ if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
+ rm -fr pyuic/uic/port_v2
+ else
+ rm -fr pyuic/uic/port_v3
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+pyqt4_use_enable() {
+ use $1 && echo "--enable=${2:-$1}"
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py
+ --confirm-license
+ --bindir=/usr/bin
+ --destdir=$(python_get_sitedir)
+ --sipdir=/usr/share/sip
+ $(use debug && echo '--debug')
+ --enable=QtCore
+ --enable=QtNetwork
+ --enable=QtScript
+ --enable=QtTest
+ --enable=QtXml
+ $(pyqt4_use_enable X QtGui)
+ $(pyqt4_use_enable X QtDesigner)
+ $(pyqt4_use_enable X QtScriptTools)
+ $(pyqt4_use_enable assistant QtAssistant)
+ $(pyqt4_use_enable assistant QtHelp)
+ $(pyqt4_use_enable opengl QtOpenGL)
+ $(pyqt4_use_enable phonon)
+ $(pyqt4_use_enable sql QtSql)
+ $(pyqt4_use_enable svg QtSvg)
+ $(pyqt4_use_enable webkit QtWebKit)
+ $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
+ CC=$(tc-getCC) CXX=$(tc-getCXX)
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
+ CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}' LFLAGS='${LDFLAGS}'"
+ echo ${myconf}
+ eval ${myconf} || return 1
+
+ # Fix insecure runpath.
+ for mod in QtCore $(use X && echo 'QtDesigner QtGui'); do
+ # Run eqmake4 to inside the qpy subdirs to prevent
+ # stripping and many QA issues
+ pushd qpy/${mod} > /dev/null || die
+ eqmake4 $(ls w_qpy*.pro)
+ popd > /dev/null || die
+ sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" ${mod}/Makefile || die "Failed to fix rpath issues"
+ done
+
+ # Fix pre-stripping of libpythonplugin.so
+ if use X; then
+ cd "${BUILDDIR}"/designer
+ eqmake4 python.pro
+ fi
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ python_need_rebuild
+
+ installation() {
+ # INSTALL_ROOT is needed for the QtDesigner module,
+ # the other Makefiles use DESTDIR.
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ }
+ python_execute_function -s installation
+
+ dodoc ChangeLog doc/pyqt4ref.txt NEWS THANKS || die
+
+ if use doc; then
+ dohtml -r doc/* || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize PyQt4
+}
+
+pkg_postrm() {
+ python_mod_cleanup PyQt4
+}