summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-12-20 14:33:50 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-12-20 14:33:50 +0000
commit9454d3ac6fd1fba74ea125c97087df9375084b22 (patch)
treea7aedeb500eb6519aa28952f97c8a64b736915d6 /dev-python/PyQt4
parentStable on sparc wrt #152498 (diff)
downloadgentoo-2-9454d3ac6fd1fba74ea125c97087df9375084b22.tar.gz
gentoo-2-9454d3ac6fd1fba74ea125c97087df9375084b22.tar.bz2
gentoo-2-9454d3ac6fd1fba74ea125c97087df9375084b22.zip
Version bump
(Portage version: 2.1.2_rc3-r7)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog8
-rw-r--r--dev-python/PyQt4/PyQt4-4.1.1.ebuild59
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.1.13
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 136ffd50fdaa..e97998a58601 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.6 2006/11/15 19:01:24 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.7 2006/12/20 14:33:50 jokey Exp $
+
+*PyQt4-4.1.1 (20 Dec 2006)
+
+ 20 Dec 2006; Markus Ullmann <jokey@gentoo.org> -PyQt4-4.1.ebuild,
+ +PyQt4-4.1.1.ebuild:
+ Version bump
15 Nov 2006; Caleb Tennis <caleb@gentoo.org> -PyQt4-4.0_beta1.ebuild:
remove old version
diff --git a/dev-python/PyQt4/PyQt4-4.1.1.ebuild b/dev-python/PyQt4/PyQt4-4.1.1.ebuild
new file mode 100644
index 000000000000..6792d52a0dde
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.1.1.ebuild,v 1.1 2006/12/20 14:33:50 jokey Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.5"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" ${S}/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/PyQt4 \
+ -b ${ROOT}/usr/bin \
+ -v ${ROOT}/usr/share/sip" #\
+# -n ${ROOT}/usr/include \
+# -o ${ROOT}/usr/$(get_libdir) \
+# -w -y qt-mt"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.1.1 b/dev-python/PyQt4/files/digest-PyQt4-4.1.1
new file mode 100644
index 000000000000..ed79afd6cfc6
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.1.1
@@ -0,0 +1,3 @@
+MD5 0e7cb6191603cd18f6f4767e1867f7bc PyQt-x11-gpl-4.1.1.tar.gz 5475244
+RMD160 7bd37cc89a9180484a84126fb927806c066e764b PyQt-x11-gpl-4.1.1.tar.gz 5475244
+SHA256 354b5d6723c88601aff9db3403ad9f6cd5e235e733d211b416f41d869e7eea89 PyQt-x11-gpl-4.1.1.tar.gz 5475244