summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-08 04:58:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-08 04:58:23 +0000
commit6c9f0cbe1674121569d6ebc9b1efbd66b3951fbb (patch)
treefb051da04bfcbab2c5a60ee69c4f2531b7377867 /dev-python/ansi2html
parentBump (diff)
downloadgentoo-2-6c9f0cbe1674121569d6ebc9b1efbd66b3951fbb.tar.gz
gentoo-2-6c9f0cbe1674121569d6ebc9b1efbd66b3951fbb.tar.bz2
gentoo-2-6c9f0cbe1674121569d6ebc9b1efbd66b3951fbb.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/ChangeLog9
-rw-r--r--dev-python/ansi2html/ansi2html-1.0.6.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/ansi2html/ChangeLog b/dev-python/ansi2html/ChangeLog
index b2fc769ea16b..6e5f18bb6d3c 100644
--- a/dev-python/ansi2html/ChangeLog
+++ b/dev-python/ansi2html/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ansi2html
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ansi2html/ChangeLog,v 1.13 2013/12/29 17:17:09 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ansi2html/ChangeLog,v 1.14 2014/01/08 04:58:23 patrick Exp $
+
+*ansi2html-1.0.6 (08 Jan 2014)
+
+ 08 Jan 2014; Patrick Lauer <patrick@gentoo.org> +ansi2html-1.0.6.ebuild:
+ Bump
29 Dec 2013; Markus Meier <maekke@gentoo.org> ansi2html-1.0.5.ebuild:
add ~arm, bug #490312
diff --git a/dev-python/ansi2html/ansi2html-1.0.6.ebuild b/dev-python/ansi2html/ansi2html-1.0.6.ebuild
new file mode 100644
index 000000000000..722098cb2777
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ansi2html/ansi2html-1.0.6.ebuild,v 1.1 2014/01/08 04:58:23 patrick Exp $
+
+EAPI=5
+
+# ordereddict is need for < 2.7, but it's not packaged (yet)
+PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="http://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w tests \
+ || die "Tests fail with ${EPYTHON}"
+}