summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-21 00:13:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-21 00:13:11 +0000
commitdfe28504eabdd624f50b04e8d28f1ce8f9b3dd49 (patch)
tree3d14442c4c4f76bd1b449d977857d919cfd5d207 /dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild
parentVersion bump, and move to ruby-fakegem. Now it needs yard and maruku for docu... (diff)
downloadgentoo-2-dfe28504eabdd624f50b04e8d28f1ce8f9b3dd49.tar.gz
gentoo-2-dfe28504eabdd624f50b04e8d28f1ce8f9b3dd49.tar.bz2
gentoo-2-dfe28504eabdd624f50b04e8d28f1ce8f9b3dd49.zip
Version bump (3.0.8). Move 3.0 and 3.1 series to separate slots.
Rationale: http://www.crummy.com/software/BeautifulSoup/3.1-problems.html (Portage version: 15123-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild
new file mode 100644
index 000000000000..159db9d86d99
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.8.ebuild,v 1.1 2009/12/21 00:13:11 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.3"
+SLOT="3.0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" BeautifulSoupTests.py
+ }
+ python_execute_function testing
+}