summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-22 15:29:59 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-22 15:29:59 +0000
commitba12dce85281d6582709ebd64557e25bf96f8800 (patch)
tree756b5c7eec41f62157609062e9d75685989b3ae8 /dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild
parentMove KEYWORDS on another line because of ekeyword's failure (diff)
downloadgentoo-2-ba12dce85281d6582709ebd64557e25bf96f8800.tar.gz
gentoo-2-ba12dce85281d6582709ebd64557e25bf96f8800.tar.bz2
gentoo-2-ba12dce85281d6582709ebd64557e25bf96f8800.zip
Add lxml to IUSE being an optional rdep, switch lxml to RDEP, add use lxml to metadata, optional rdep html5lib blocked by Bug 471002, re-add pypy2 support to 4.2.0, patch to fix tests for 4.2.0
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild
index 35f90600d2a6..cd5beb513e45 100644
--- a/dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild,v 1.1 2013/05/18 07:01:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.2.0.ebuild,v 1.2 2013/05/22 15:29:59 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy2_0 )
inherit distutils-r1
@@ -18,16 +18,19 @@ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc test"
+# new html5 awaits keywording of html5lib in Bug 471002
+IUSE="doc +lxml test"
+# pending Bug 471002; html5? ( dev-python/html5lib[$(python_gen_usedep 'python{2_6,2_7}' pypy2_0)] )
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- )"
+RDEPEND="lxml? ( dev-python/lxml[$(python_gen_usedep 'python{2_6,2_7}' 'python3*')] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/bfs-${PV}-no-lxml.patch )
+
python_compile_all() {
if use doc; then
emake -C doc html