summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-25 04:50:57 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-25 04:50:57 +0000
commitbe3b9c93626843f1d763f1f0d16721468a3f95cc (patch)
tree0378078d4310c741b70e7dcc797a0f87e2ee8cf6 /dev-python/boto
parentUpdate to EAPI5 to clean up the ebuilds a bit. Allow disabling both consoleki... (diff)
downloadgentoo-2-be3b9c93626843f1d763f1f0d16721468a3f95cc.tar.gz
gentoo-2-be3b9c93626843f1d763f1f0d16721468a3f95cc.tar.bz2
gentoo-2-be3b9c93626843f1d763f1f0d16721468a3f95cc.zip
Version bump, migrate to distutils-r1 (bug #453922).
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog9
-rw-r--r--dev-python/boto/boto-2.7.0.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 86ed63125985..5de1ef12a998 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.52 2012/09/29 21:55:05 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.53 2013/01/25 04:50:57 radhermit Exp $
+
+*boto-2.7.0 (25 Jan 2013)
+
+ 25 Jan 2013; Tim Harder <radhermit@gentoo.org> +boto-2.7.0.ebuild:
+ Version bump, migrate to distutils-r1 (bug #453922).
*boto-2.6.0 (29 Sep 2012)
diff --git a/dev-python/boto/boto-2.7.0.ebuild b/dev-python/boto/boto-2.7.0.ebuild
new file mode 100644
index 000000000000..0b55c96524ed
--- /dev/null
+++ b/dev-python/boto/boto-2.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.7.0.ebuild,v 1.1 2013/01/25 04:50:57 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}