summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-06-06 15:47:25 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-06-06 15:47:25 +0000
commit8543641ba6585313209008002a7b45db4d621733 (patch)
tree2c3091d29dc26a667dc965dc8ae71f21402f6b77 /dev-python/bottle
parentVersion bump bottle to 0.11.7 (fixes bug 509350) (diff)
downloadgentoo-2-8543641ba6585313209008002a7b45db4d621733.tar.gz
gentoo-2-8543641ba6585313209008002a7b45db4d621733.tar.bz2
gentoo-2-8543641ba6585313209008002a7b45db4d621733.zip
Version bump bottle to 0.12.6
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/ChangeLog7
-rw-r--r--dev-python/bottle/bottle-0.12.6.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index 62fd929622ff..c89a4201a7bb 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.24 2014/06/06 15:44:16 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.25 2014/06/06 15:47:25 djc Exp $
+
+*bottle-0.12.6 (06 Jun 2014)
+
+ 06 Jun 2014; Dirkjan Ochtman <djc@gentoo.org> +bottle-0.12.6.ebuild:
+ Version bump bottle to 0.12.6
*bottle-0.11.7 (06 Jun 2014)
diff --git a/dev-python/bottle/bottle-0.12.6.ebuild b/dev-python/bottle/bottle-0.12.6.ebuild
new file mode 100644
index 000000000000..e944e77fd7e2
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.12.6.ebuild,v 1.1 2014/06/06 15:47:25 djc Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}