summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-03 05:45:53 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-03 05:45:53 +0000
commit9dec091f7829e5c38b705a941682d2b1fc8818f8 (patch)
tree2adbf317c20e6072718bf8a6f618016ae53c13a6 /dev-python/bottle
parentversion bump, remove old (bug #531338) (diff)
downloadgentoo-2-9dec091f7829e5c38b705a941682d2b1fc8818f8.tar.gz
gentoo-2-9dec091f7829e5c38b705a941682d2b1fc8818f8.tar.bz2
gentoo-2-9dec091f7829e5c38b705a941682d2b1fc8818f8.zip
re-add 0.11.7 stop gap for sake of stable ppc keywords not yet done in #530406
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/ChangeLog7
-rw-r--r--dev-python/bottle/bottle-0.11.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index 12856b41b00b..b466f2701a85 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.44 2015/02/03 02:26:39 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.45 2015/02/03 05:45:53 idella4 Exp $
+
+*bottle-0.11.7 (03 Feb 2015)
+
+ 03 Feb 2015; Ian Delaney <idella4@gentoo.org> +bottle-0.11.7.ebuild:
+ re-add 0.11.7 stop gap for sake of stable ppc keywords not yet done in #530406
*bottle-0.12.8 (03 Feb 2015)
diff --git a/dev-python/bottle/bottle-0.11.7.ebuild b/dev-python/bottle/bottle-0.11.7.ebuild
new file mode 100644
index 000000000000..0e2a8535d040
--- /dev/null
+++ b/dev-python/bottle/bottle-0.11.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.11.7.ebuild,v 1.11 2015/02/03 05:45:53 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0)
+inherit distutils-r1
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}