summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-09 02:07:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-09 02:07:29 +0000
commit994816acb55537e04d763e251910aaac1b9f665f (patch)
tree8d82931e5e25a08101f5c629787867c3c3f92f6b /dev-python/bsddb3/bsddb3-6.0.0.ebuild
parentDon't clobber distutils-r1_python_prepare_all. (diff)
downloadgentoo-2-994816acb55537e04d763e251910aaac1b9f665f.tar.gz
gentoo-2-994816acb55537e04d763e251910aaac1b9f665f.tar.bz2
gentoo-2-994816acb55537e04d763e251910aaac1b9f665f.zip
Bump
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/bsddb3/bsddb3-6.0.0.ebuild')
-rw-r--r--dev-python/bsddb3/bsddb3-6.0.0.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/bsddb3/bsddb3-6.0.0.ebuild b/dev-python/bsddb3/bsddb3-6.0.0.ebuild
new file mode 100644
index 000000000000..285be91a7a8d
--- /dev/null
+++ b/dev-python/bsddb3/bsddb3-6.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-6.0.0.ebuild,v 1.1 2013/07/09 02:07:29 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+
+inherit db-use distutils-r1 multilib
+
+DESCRIPTION="Python bindings for Berkeley DB"
+HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm http://pypi.python.org/pypi/bsddb3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=sys-libs/db-4.8.30"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS=( ChangeLog TODO.txt )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local DB_VER
+ if has_version sys-libs/db:5.1; then
+ DB_VER="5.1"
+ elif has_version sys-libs/db:5.0; then
+ DB_VER="5.0"
+ else
+ DB_VER="4.8"
+ fi
+ sed -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" -i setup2.py setup3.py || die "sed failed"
+}
+
+src_compile() {
+ distutils-r1_src_compile \
+ --berkeley-db="${EPREFIX}/usr" \
+ --berkeley-db-incdir="${EPREFIX}$(db_includedir ${DB_VER})" \
+ --berkeley-db-libdir="${EPREFIX}/usr/$(get_libdir)"
+}
+
+python_test() {
+ # https://sourceforge.net/p/pybsddb/bugs/72/
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ if [[ "${EPYTHON}" == python2* ]]; then
+ "${PYTHON}" build/lib/bsddb3/tests/test_all.py
+ elif [[ "${EPYTHON}" == python3* ]]; then
+ "${PYTHON}" setup.py build
+ einfo "all 500 tests are run silently and may take a number of minutes to complete"
+ "${PYTHON}" ./test3.py
+ fi
+}
+
+python_install() {
+ rm -fr "${ED}$(python_get_sitedir)/bsddb3/tests"
+
+ if use doc; then
+ dohtml -r docs/html/* || die "dohtml failed"
+ fi
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ local HTML_DOCS=( docs/html/. )
+ distutils-r1_python_install_all
+}