summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCorentin Chary <iksaif@gentoo.org>2012-07-29 19:57:07 +0000
committerCorentin Chary <iksaif@gentoo.org>2012-07-29 19:57:07 +0000
commite11f38df53605362b20d8aab76965aab9267441f (patch)
treeaca76baaed7667caf1ff543f5d502f1fac26a451 /dev-python/celery
parentImpose -odbc for wxGTK because of conflicting types between GDL types and SQL... (diff)
downloadgentoo-2-e11f38df53605362b20d8aab76965aab9267441f.tar.gz
gentoo-2-e11f38df53605362b20d8aab76965aab9267441f.tar.bz2
gentoo-2-e11f38df53605362b20d8aab76965aab9267441f.zip
Bump to 3.0.4.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/ChangeLog8
-rw-r--r--dev-python/celery/celery-3.0.4.ebuild (renamed from dev-python/celery/celery-3.0.1.ebuild)8
-rw-r--r--dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch37
3 files changed, 9 insertions, 44 deletions
diff --git a/dev-python/celery/ChangeLog b/dev-python/celery/ChangeLog
index f0e957e31f5f..be275bb3c7d4 100644
--- a/dev-python/celery/ChangeLog
+++ b/dev-python/celery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/celery
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.3 2012/07/17 15:10:59 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.4 2012/07/29 19:57:07 iksaif Exp $
+
+*celery-3.0.4 (29 Jul 2012)
+
+ 29 Jul 2012; Corentin Chary <iksaif@gentoo.org> +celery-3.0.4.ebuild,
+ -celery-3.0.1.ebuild, -files/celery-3.0.1-fix-setuptools-import.patch:
+ Bump to 3.0.4.
*celery-2.5.5 (17 Jul 2012)
*celery-3.0.1 (17 Jul 2012)
diff --git a/dev-python/celery/celery-3.0.1.ebuild b/dev-python/celery/celery-3.0.4.ebuild
index 91b2c0bfd03b..8b056ecc87e1 100644
--- a/dev-python/celery/celery-3.0.1.ebuild
+++ b/dev-python/celery/celery-3.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.1.ebuild,v 1.1 2012/07/17 15:10:59 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.4.ebuild,v 1.1 2012/07/29 19:57:07 iksaif Exp $
EAPI="4"
@@ -12,7 +12,7 @@ RESTRICT_PYTHON_ABIS="2.[5-6]"
SUPPORT_PYTHON_ABIS="1"
DISTUTILS_SRC_TEST="nosetests"
-inherit distutils eutils
+inherit distutils
DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
@@ -53,10 +53,6 @@ DEPEND="${RDEPEND}
)
dev-python/setuptools"
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0.1-fix-setuptools-import.patch"
-}
-
src_test() {
testing() {
nosetests --py3where build-${PYTHON_ABI}/lib/${PN}/tests
diff --git a/dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch b/dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch
deleted file mode 100644
index ca9542178f66..000000000000
--- a/dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- setup.py.orig 2012-07-17 08:31:53.346133430 +0200
-+++ setup.py 2012-07-17 08:32:08.296813785 +0200
-@@ -8,6 +8,16 @@
- raise Exception('Celery requires Python 2.5 or higher.')
-
- try:
-+ from setuptools import setup, find_packages
-+ from setuptools.command.test import test
-+except ImportError:
-+ raise
-+ from ez_setup import use_setuptools
-+ use_setuptools()
-+ from setuptools import setup, find_packages # noqa
-+ from setuptools.command.test import test # noqa
-+
-+try:
- orig_path = sys.path[:]
- for path in (os.path.curdir, os.getcwd()):
- if path in sys.path:
-@@ -32,17 +42,6 @@
- except:
- pass
-
--
--try:
-- from setuptools import setup, find_packages
-- from setuptools.command.test import test
--except ImportError:
-- raise
-- from ez_setup import use_setuptools
-- use_setuptools()
-- from setuptools import setup, find_packages # noqa
-- from setuptools.command.test import test # noqa
--
- NAME = 'celery'
- entrypoints = {}
- extra = {}