summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-03-30 20:59:27 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-03-30 20:59:27 +0000
commitf1e763d9df914e33247f8559e032002d9a4aae3f (patch)
tree1c961b008a6b80a7c585891a50f8c559c46243ab /dev-python/cffi
parentBackport the :0 slot switch to pypy-2.0.2 since we have binpackages for this ... (diff)
downloadgentoo-2-f1e763d9df914e33247f8559e032002d9a4aae3f.tar.gz
gentoo-2-f1e763d9df914e33247f8559e032002d9a4aae3f.tar.bz2
gentoo-2-f1e763d9df914e33247f8559e032002d9a4aae3f.zip
Version bump cffi to 0.8.2.
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-0.8.2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index c389f73b7a91..77c58733b84c 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.27 2014/03/30 20:53:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.28 2014/03/30 20:59:27 djc Exp $
+
+*cffi-0.8.2 (30 Mar 2014)
+
+ 30 Mar 2014; Dirkjan Ochtman <djc@gentoo.org> +cffi-0.8.2.ebuild:
+ Version bump cffi to 0.8.2.
30 Mar 2014; Dirkjan Ochtman <djc@gentoo.org> -cffi-0.7.2.ebuild,
-cffi-0.8.ebuild:
diff --git a/dev-python/cffi/cffi-0.8.2.ebuild b/dev-python/cffi/cffi-0.8.2.ebuild
new file mode 100644
index 000000000000..9a966247d877
--- /dev/null
+++ b/dev-python/cffi/cffi-0.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.2.ebuild,v 1.1 2014/03/30 20:59:27 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code."
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/build/
+}