summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-12 22:15:19 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-12 22:15:19 +0000
commit0e93a523ca06076ae2fa971fcd0215e444c8e950 (patch)
tree65f753dfd059569417928e48094f4a6b61dac096 /dev-python/cliff
parentFix the dependencies and supported implementations. Enable tests. Update HOME... (diff)
downloadgentoo-2-0e93a523ca06076ae2fa971fcd0215e444c8e950.tar.gz
gentoo-2-0e93a523ca06076ae2fa971fcd0215e444c8e950.tar.bz2
gentoo-2-0e93a523ca06076ae2fa971fcd0215e444c8e950.zip
Remove unnecessary dep on pyparsing (it belongs to cmd2). Enable tests. Drop old.
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/ChangeLog7
-rw-r--r--dev-python/cliff/cliff-1.3.1.ebuild22
-rw-r--r--dev-python/cliff/cliff-1.4.ebuild29
3 files changed, 24 insertions, 34 deletions
diff --git a/dev-python/cliff/ChangeLog b/dev-python/cliff/ChangeLog
index 8564e94127e8..35d4f9c33e85 100644
--- a/dev-python/cliff/ChangeLog
+++ b/dev-python/cliff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cliff
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.4 2013/09/10 05:26:54 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.5 2013/09/12 22:15:19 mgorny Exp $
+
+ 12 Sep 2013; Michał Górny <mgorny@gentoo.org> -cliff-1.3.1.ebuild,
+ cliff-1.4.ebuild:
+ Remove unnecessary dep on pyparsing (it belongs to cmd2). Enable tests. Drop
+ old.
10 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> cliff-1.4.ebuild:
fixing broken pyparsing dep
diff --git a/dev-python/cliff/cliff-1.3.1.ebuild b/dev-python/cliff/cliff-1.3.1.ebuild
deleted file mode 100644
index 9b81a1448a57..000000000000
--- a/dev-python/cliff/cliff-1.3.1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.3.1.ebuild,v 1.1 2013/03/11 02:42:01 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_2 )
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/dreamhost/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- dev-python/prettytable
- dev-python/cmd2"
diff --git a/dev-python/cliff/cliff-1.4.ebuild b/dev-python/cliff/cliff-1.4.ebuild
index cbc07a552a3a..8f3c90b1336a 100644
--- a/dev-python/cliff/cliff-1.4.ebuild
+++ b/dev-python/cliff/cliff-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.4.ebuild,v 1.2 2013/09/10 05:26:54 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.4.ebuild,v 1.3 2013/09/12 22:15:19 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 python3_2 )
@@ -14,16 +14,23 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6
- <dev-python/prettytable-0.8
- >=dev-python/cmd2-0.6.4[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-1.5.7:py2
- dev-python/pyparsing:py3"
-
-python_prepare() {
- sed -i '29,37d' "setup.py" || die
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '29,37d' "setup.py" || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests || die "Tests fail with ${EPYTHON}"
}