summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-19 20:17:06 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-19 20:17:06 +0000
commit2d32db307d76d33249bbecc2e3f6c8b14b622571 (patch)
tree03e99d83034ec2e692c135190d1cbdf3938224c9 /dev-python/clint
parentUpdate prototype headers, drop Mandrake/readline patches that are not needed,... (diff)
downloadgentoo-2-2d32db307d76d33249bbecc2e3f6c8b14b622571.tar.gz
gentoo-2-2d32db307d76d33249bbecc2e3f6c8b14b622571.tar.bz2
gentoo-2-2d32db307d76d33249bbecc2e3f6c8b14b622571.zip
add version 0.4.1
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/ChangeLog7
-rw-r--r--dev-python/clint/clint-0.4.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/clint/ChangeLog b/dev-python/clint/ChangeLog
index fa764fb59280..e6fa51ce5457 100644
--- a/dev-python/clint/ChangeLog
+++ b/dev-python/clint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/clint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v 1.2 2014/10/11 05:02:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v 1.3 2014/10/19 20:17:06 alunduil Exp $
+
+*clint-0.4.1 (19 Oct 2014)
+
+ 19 Oct 2014; Alex Brandt <alunduil@gentoo.org> +clint-0.4.1.ebuild:
+ add version 0.4.1
*clint-0.3.1-r1 (11 Oct 2014)
diff --git a/dev-python/clint/clint-0.4.1.ebuild b/dev-python/clint/clint-0.4.1.ebuild
new file mode 100644
index 000000000000..3859ff2237cf
--- /dev/null
+++ b/dev-python/clint/clint-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/clint-0.4.1.ebuild,v 1.1 2014/10/19 20:17:06 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}