summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-11 05:02:55 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-11 05:02:55 +0000
commitb77361a2d35b6823d83914fedbe2176e21243f3b (patch)
tree126a20cf7890238cb45aab7990aef5313a14d22e /dev-python/clint
parentCleanup old EAPI1 ebuild. (diff)
downloadgentoo-2-b77361a2d35b6823d83914fedbe2176e21243f3b.tar.gz
gentoo-2-b77361a2d35b6823d83914fedbe2176e21243f3b.tar.bz2
gentoo-2-b77361a2d35b6823d83914fedbe2176e21243f3b.zip
revbump; add patch to correct install of data files to a most unexpected location in only 0.3.1, authority given to commit by maintainer
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/ChangeLog10
-rw-r--r--dev-python/clint/clint-0.3.1-r1.ebuild41
-rw-r--r--dev-python/clint/files/clint-setup.patch15
3 files changed, 64 insertions, 2 deletions
diff --git a/dev-python/clint/ChangeLog b/dev-python/clint/ChangeLog
index 6444dd87b7db..fa764fb59280 100644
--- a/dev-python/clint/ChangeLog
+++ b/dev-python/clint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/clint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v 1.1 2014/10/07 17:58:44 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v 1.2 2014/10/11 05:02:55 idella4 Exp $
+
+*clint-0.3.1-r1 (11 Oct 2014)
+
+ 11 Oct 2014; Ian Delaney <idella4@gentoo.org> +clint-0.3.1-r1.ebuild,
+ +files/clint-setup.patch:
+ revbump; add patch to correct install of data files to a most unexpected
+ location in only 0.3.1, authority given to commit by maintainer
*clint-0.3.7 (07 Oct 2014)
*clint-0.3.1 (07 Oct 2014)
@@ -8,4 +15,3 @@
07 Oct 2014; Alex Brandt <alunduil@gentoo.org> +clint-0.3.1.ebuild,
+clint-0.3.7.ebuild, +metadata.xml:
add ebuild written by me
-
diff --git a/dev-python/clint/clint-0.3.1-r1.ebuild b/dev-python/clint/clint-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..abd38ea95a7f
--- /dev/null
+++ b/dev-python/clint/clint-0.3.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/clint-0.3.1-r1.ebuild,v 1.1 2014/10/11 05:02:55 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+# Prevent install of files to wrong location
+PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/clint/files/clint-setup.patch b/dev-python/clint/files/clint-setup.patch
new file mode 100644
index 000000000000..960dc99be429
--- /dev/null
+++ b/dev-python/clint/files/clint-setup.patch
@@ -0,0 +1,15 @@
+setup.py installs data files to /usr/ !!!??!!
+diff -ur clint-0.3.1.orig/setup.py clint-0.3.1/setup.py
+--- setup.py 2012-01-16 22:25:54.000000000 +0800
++++ setup.py 2014-10-11 12:20:29.174133572 +0800
+@@ -29,10 +29,6 @@
+ author='Kenneth Reitz',
+ author_email='me@kennethreitz.com',
+ url='https://github.com/kennethreitz/clint',
+- data_files=[
+- 'README.rst',
+- 'HISTORY.rst',
+- ],
+ packages= [
+ 'clint',
+ 'clint.textui',