summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-06-10 17:53:22 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-06-10 17:53:22 +0000
commit7db97ecb8839b0e6be41fce4cbbe4a08ab86709a (patch)
tree3a269196283af142d8f75f30f010919edff4058d /dev-python/colout
parentDrop dep on app-misc/strigi, is not needed anymore by Nikoli <nikoli@lavabit.... (diff)
downloadgentoo-2-7db97ecb8839b0e6be41fce4cbbe4a08ab86709a.tar.gz
gentoo-2-7db97ecb8839b0e6be41fce4cbbe4a08ab86709a.tar.bz2
gentoo-2-7db97ecb8839b0e6be41fce4cbbe4a08ab86709a.zip
Remove 'examples' USE as package does not have examples. Remove 'test' use as package does not have tests. Add to deps and to REQUIRED_USE. Fix license information in README.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-python/colout')
-rw-r--r--dev-python/colout/ChangeLog8
-rw-r--r--dev-python/colout/colout-0.1.ebuild31
2 files changed, 23 insertions, 16 deletions
diff --git a/dev-python/colout/ChangeLog b/dev-python/colout/ChangeLog
index a47d757e6afb..81be4fc65686 100644
--- a/dev-python/colout/ChangeLog
+++ b/dev-python/colout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/colout
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colout/ChangeLog,v 1.1 2013/06/06 15:12:47 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colout/ChangeLog,v 1.2 2013/06/10 17:53:22 maksbotan Exp $
+
+ 10 Jun 2013; Maxim Koltsov <maksbotan@gentoo.org> colout-0.1.ebuild,
+ metadata.xml:
+ Remove 'examples' USE as package does not have examples. Remove 'test' use as
+ package does not have tests. Add to deps and to REQUIRED_USE. Fix license
+ information in README.
*colout-0.1 (06 Jun 2013)
diff --git a/dev-python/colout/colout-0.1.ebuild b/dev-python/colout/colout-0.1.ebuild
index 4d53d89c5514..0da6f471cedc 100644
--- a/dev-python/colout/colout-0.1.ebuild
+++ b/dev-python/colout/colout-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colout/colout-0.1.ebuild,v 1.1 2013/06/06 15:12:47 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colout/colout-0.1.ebuild,v 1.2 2013/06/10 17:53:22 maksbotan Exp $
EAPI=5
@@ -14,23 +14,24 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
+IUSE=""
-RDEPEND="dev-python/pygments
- dev-python/Babel"
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/Babel[$(python_gen_usedep 'python2*')]
+"
-src_test() {
- testing() {
- PYTHONPATH="." "$(PYTHON)" run-tests.py
- }
- python_execute_function testing
-}
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-src_install() {
- distutils-r1_src_install
+src_prepare() {
+ #PyPi tarball has wrong (old, evidently) README. Upstream uses GPL-3.
+ sed -e 's:BSD licensed:GPL-3 licensed:' -i README || die
+ distutils-r1_src_prepare
+}
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
+pkg_postinst() {
+ if [[ "${PYTHON_TARGETS}" == *python3* ]]; then
+ ewarn "Though ${PN} supports Python 3, Babel does not, thus it's number parsing feature won't be used."
+ ewarn "If you need it, use Python 2."
fi
}