summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-29 12:52:31 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-29 12:52:31 +0000
commit22c730ea8249ecb0dd7dfdc9617bff605dd1e9c3 (patch)
tree2d49d68133a371a1bf75ebc729d98a72e74c3a5d /dev-python/columnize/columnize-0.3.5-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-22c730ea8249ecb0dd7dfdc9617bff605dd1e9c3.tar.gz
gentoo-2-22c730ea8249ecb0dd7dfdc9617bff605dd1e9c3.tar.bz2
gentoo-2-22c730ea8249ecb0dd7dfdc9617bff605dd1e9c3.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/columnize/columnize-0.3.5-r1.ebuild')
-rw-r--r--dev-python/columnize/columnize-0.3.5-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/columnize/columnize-0.3.5-r1.ebuild b/dev-python/columnize/columnize-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..f0491b4797d1
--- /dev/null
+++ b/dev-python/columnize/columnize-0.3.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/columnize/columnize-0.3.5-r1.ebuild,v 1.1 2014/12/29 12:52:31 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Format a simple (i.e. not nested) list into aligned columns"
+HOMEPAGE="http://code.google.com/p/pycolumnize/ http://pypi.python.org/pypi/columnize"
+SRC_URI="http://pycolumnize.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed"
+}