summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-02-17 22:48:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-02-17 22:48:13 +0000
commitb43a599f3d23c35b01768c4faf58a4cff4544a85 (patch)
treecd1b9c33857e165647f913086c12d5b9362ad837 /dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
parentBugfix bump, thanks to Fabio Correa (bug #304515). (diff)
downloadgentoo-2-b43a599f3d23c35b01768c4faf58a4cff4544a85.tar.gz
gentoo-2-b43a599f3d23c35b01768c4faf58a4cff4544a85.tar.bz2
gentoo-2-b43a599f3d23c35b01768c4faf58a4cff4544a85.zip
Do not install pointless .la file, bug #299101. Install documentation in one place, bug #299102.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
index 5d08b16ed093..644857c66d63 100644
--- a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.15 2010/01/20 00:11:09 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.16 2010/02/17 22:48:13 eva Exp $
EAPI="2"
PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
@@ -41,7 +41,7 @@ src_configure() {
configuration() {
econf \
- --docdir="${EPREFIX}"/usr/share/doc/dbus-python-${PV} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
$(use_enable doc api-docs)
}
python_execute_function -s configuration
@@ -65,6 +65,8 @@ src_install() {
insinto /usr/share/doc/${PF}/
doins -r examples || die
fi
+
+ find "${D}" -name "*.la" -delete || die "removing *.la files failed"
}
pkg_postinst() {