summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-14 19:13:20 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-14 19:13:20 +0000
commite7cb37580b8985045d53b231f63a939a987224ac (patch)
treeed966fa21a29485badc6793a505b66f995ee99a2 /dev-python/diff-match-patch
parentMigrated to distutils-r1. (diff)
downloadgentoo-2-e7cb37580b8985045d53b231f63a939a987224ac.tar.gz
gentoo-2-e7cb37580b8985045d53b231f63a939a987224ac.tar.bz2
gentoo-2-e7cb37580b8985045d53b231f63a939a987224ac.zip
Convert to distutils-r1.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/diff-match-patch')
-rw-r--r--dev-python/diff-match-patch/ChangeLog8
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20120106-r1.ebuild25
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/diff-match-patch/ChangeLog b/dev-python/diff-match-patch/ChangeLog
index fd626a99fe12..42c238ab3ef1 100644
--- a/dev-python/diff-match-patch/ChangeLog
+++ b/dev-python/diff-match-patch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/diff-match-patch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/ChangeLog,v 1.12 2013/07/06 15:57:47 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/ChangeLog,v 1.13 2013/12/14 19:13:20 mgorny Exp $
+
+*diff-match-patch-20120106-r1 (14 Dec 2013)
+
+ 14 Dec 2013; Michał Górny <mgorny@gentoo.org>
+ +diff-match-patch-20120106-r1.ebuild:
+ Convert to distutils-r1.
06 Jul 2013; Amadeusz Żołnowski <aidecoe@gentoo.org>
diff-match-patch-20110725.1.ebuild, diff-match-patch-20120106.ebuild:
diff --git a/dev-python/diff-match-patch/diff-match-patch-20120106-r1.ebuild b/dev-python/diff-match-patch/diff-match-patch-20120106-r1.ebuild
new file mode 100644
index 000000000000..5cee33af498d
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20120106-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/diff-match-patch-20120106-r1.ebuild,v 1.1 2013/12/14 19:13:20 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="http://code.google.com/p/google-diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}