summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-18 15:24:01 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-18 15:24:01 +0000
commite27c83217e805f66e7019b4a1c071f94992857e5 (patch)
tree8567410b4b81157bed4ff2a0901167bfc0d3f3cb /dev-python/django-auth-ldap
parentVersion bump (bug #470262). (diff)
downloadgentoo-2-e27c83217e805f66e7019b4a1c071f94992857e5.tar.gz
gentoo-2-e27c83217e805f66e7019b4a1c071f94992857e5.tar.bz2
gentoo-2-e27c83217e805f66e7019b4a1c071f94992857e5.zip
revbump; migrate -> distutils-r1, updated test phase, patch to avoid d'loading in doc build
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/ChangeLog9
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.1.4-r1.ebuild45
-rw-r--r--dev-python/django-auth-ldap/files/docs.patch18
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/django-auth-ldap/ChangeLog b/dev-python/django-auth-ldap/ChangeLog
index 33c9795664d0..e8f61ef8d834 100644
--- a/dev-python/django-auth-ldap/ChangeLog
+++ b/dev-python/django-auth-ldap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/django-auth-ldap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/ChangeLog,v 1.7 2013/05/05 15:09:34 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/ChangeLog,v 1.8 2013/05/18 15:24:01 idella4 Exp $
+
+*django-auth-ldap-1.1.4-r1 (18 May 2013)
+
+ 18 May 2013; Ian Delaney <idella4@gentoo.org>
+ +django-auth-ldap-1.1.4-r1.ebuild, +files/docs.patch:
+ revbump; migrate -> distutils-r1, updated test phase, patch to avoid d'loading
+ in doc build
*django-auth-ldap-1.1.4 (05 May 2013)
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.1.4-r1.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..d1ad34121c95
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.1.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/django-auth-ldap-1.1.4-r1.ebuild,v 1.1 2013/05/18 15:24:01 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="http://pypi.python.org/pypi/django-auth-ldap http://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+PYTHON_MODNAME="django_auth_ldap"
+
+RDEPEND=">=dev-python/django-1.3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/python-ldap[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ if ! "${PYTHON}" -c \
+ "from django.conf import global_settings;global_settings.SECRET_KEY='green'" -m django_auth_ldap.tests
+ then
+ die "tests failed under ${EPYTHON}"
+ else
+ einfo "tests passed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-auth-ldap/files/docs.patch b/dev-python/django-auth-ldap/files/docs.patch
new file mode 100644
index 000000000000..c4e918fac538
--- /dev/null
+++ b/dev-python/django-auth-ldap/files/docs.patch
@@ -0,0 +1,18 @@
+Avoid unwanted d'loading for un-needed ojects.inv files
+diff -ur django-auth-ldap-1.1.4.orig/docs/source/conf.py django-auth-ldap-1.1.4/docs/source/conf.py
+--- docs/source/conf.py 2013-03-10 06:01:09.000000000 +0800
++++ docs/source/conf.py 2013-05-18 23:14:35.761187583 +0800
+@@ -29,13 +29,6 @@
+ 'daldocs',
+ ]
+
+-intersphinx_mapping = {
+- 'python': ('http://docs.python.org/', None),
+- 'django': ('https://docs.djangoproject.com/en/dev/',
+- 'https://docs.djangoproject.com/en/dev/_objects/'),
+- 'pythonldap': ('http://python-ldap.org/doc/html/', None),
+-}
+-
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['../_templates']
+