summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-02 06:12:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-02 06:12:16 +0000
commit5733d5fa13b219af8932b9572b3d2eb2d5eeba83 (patch)
treed4f29d1c63f40cf2703e617e8fe9a12669d4158d /dev-python/django-oauth-plus
parentStable for x86, wrt bug #486742 (diff)
downloadgentoo-2-5733d5fa13b219af8932b9572b3d2eb2d5eeba83.tar.gz
gentoo-2-5733d5fa13b219af8932b9572b3d2eb2d5eeba83.tar.bz2
gentoo-2-5733d5fa13b219af8932b9572b3d2eb2d5eeba83.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/ChangeLog8
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.1.5.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/django-oauth-plus/ChangeLog b/dev-python/django-oauth-plus/ChangeLog
index 8710908f8e9d..8d9c5a34069a 100644
--- a/dev-python/django-oauth-plus/ChangeLog
+++ b/dev-python/django-oauth-plus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-oauth-plus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.6 2013/08/26 03:08:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.7 2013/10/02 06:12:16 patrick Exp $
+
+*django-oauth-plus-2.1.5 (02 Oct 2013)
+
+ 02 Oct 2013; Patrick Lauer <patrick@gentoo.org>
+ +django-oauth-plus-2.1.5.ebuild:
+ Bump
*django-oauth-plus-2.1.4 (26 Aug 2013)
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.1.5.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.1.5.ebuild
new file mode 100644
index 000000000000..324cd694a5b8
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.1.5.ebuild,v 1.1 2013/10/02 06:12:16 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="http://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/django-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_hg[${PYTHON_USEDEP}]
+ test? ( dev-python/south[${PYTHON_USEDEP}] )"
+
+python_test() {
+ if "${PYTHON}" oauth_provider/runtests/manage.py test; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}