summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-01 15:49:15 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-01 15:49:15 +0000
commit82d9d991dc7735fe162808393f568fdf031f83bf (patch)
treee637096c38dbe2f796b810fc38a9145b4c2f0b59 /dev-python/django-recaptcha
parentAdd new global USE flag qt5. (diff)
downloadgentoo-2-82d9d991dc7735fe162808393f568fdf031f83bf.tar.gz
gentoo-2-82d9d991dc7735fe162808393f568fdf031f83bf.tar.bz2
gentoo-2-82d9d991dc7735fe162808393f568fdf031f83bf.zip
revbump, drop pypy to match django, edit recaptcha-fields patch to import added missing source file, add nose for test phase, drop old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-recaptcha')
-rw-r--r--dev-python/django-recaptcha/ChangeLog12
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.4.ebuild29
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.5.ebuild28
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild32
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.6-r2.ebuild36
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild27
-rw-r--r--dev-python/django-recaptcha/files/django-recaptcha-fields.patch2
-rw-r--r--dev-python/django-recaptcha/files/django-recaptcha-settings.patch1
-rw-r--r--dev-python/django-recaptcha/files/test_settings.py14
9 files changed, 62 insertions, 119 deletions
diff --git a/dev-python/django-recaptcha/ChangeLog b/dev-python/django-recaptcha/ChangeLog
index 684e0e61e134..d9e89339ed67 100644
--- a/dev-python/django-recaptcha/ChangeLog
+++ b/dev-python/django-recaptcha/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/django-recaptcha
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/ChangeLog,v 1.5 2013/03/06 19:13:49 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/ChangeLog,v 1.6 2013/06/01 15:49:15 idella4 Exp $
+
+*django-recaptcha-0.0.6-r2 (01 Jun 2013)
+
+ 01 Jun 2013; Ian Delaney <idella4@gentoo.org>
+ +django-recaptcha-0.0.6-r2.ebuild, +files/test_settings.py,
+ -django-recaptcha-0.0.4.ebuild, -django-recaptcha-0.0.5.ebuild,
+ -django-recaptcha-0.0.6-r1.ebuild, -django-recaptcha-0.0.6.ebuild,
+ files/django-recaptcha-fields.patch, files/django-recaptcha-settings.patch:
+ revbump, drop pypy to match django, edit recaptcha-fields patch to import
+ added missing source file, add nose for test phase, drop old
*django-recaptcha-0.0.6-r1 (06 Mar 2013)
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.4.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.4.ebuild
deleted file mode 100644
index 406207b02f74..000000000000
--- a/dev-python/django-recaptcha/django-recaptcha-0.0.4.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.4.ebuild,v 1.1 2012/08/02 17:17:47 iksaif Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_MODNAME="captcha"
-
-inherit distutils
-
-DESCRIPTION="Django recaptcha form field/widget app"
-HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/django-registration
- dev-python/setuptools"
-
-# Test not supported, missing dependency
-# test? ( >=dev-python/django-setuptest-0.0.6 )
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.5.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.5.ebuild
deleted file mode 100644
index a9418cda0e3f..000000000000
--- a/dev-python/django-recaptcha/django-recaptcha-0.0.5.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.5.ebuild,v 1.1 2012/10/25 10:55:11 iksaif Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_MODNAME="captcha"
-
-inherit distutils
-
-DESCRIPTION="Django recaptcha form field/widget app"
-HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-# Test not supported, missing dependency
-# test? ( >=dev-python/django-setuptest-0.0.6 )
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild
deleted file mode 100644
index 57fad45bf7c8..000000000000
--- a/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.6-r1.ebuild,v 1.1 2013/03/06 19:13:49 idella4 Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="Django recaptcha form field/widget app"
-HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( >=dev-python/django-setuptest-0.0.6 )"
-
-# set variables for testsuite
-PATCHES=( "${FILESDIR}"/${PN}-fields.patch
- "${FILESDIR}"/${PN}-settings.patch )
-
-python_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- "${PYTHON}" captcha/tests.py && einfo "tests passed with ${PYTHON}" \
- || die "Tests failed"
-}
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.6-r2.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.6-r2.ebuild
new file mode 100644
index 000000000000..228ace0036f2
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-0.0.6-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.6-r2.ebuild,v 1.1 2013/06/01 15:49:15 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit distutils-r1
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/praekelt/${PN}/archive/0.0.6.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/django-setuptest-0.0.6[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Add missing source file rather than make our own
+ cp -r "${FILESDIR}"/test_settings.py captcha || die
+ local PATCHES=( "${FILESDIR}"/${PN}-fields.patch )
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Use of nosetests gives confirmation that tests are run, "${PYTHON}" doesn't
+ nosetests captcha/tests.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild b/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild
deleted file mode 100644
index 96d2793bb27f..000000000000
--- a/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-0.0.6.ebuild,v 1.2 2013/03/06 19:13:49 idella4 Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_MODNAME="captcha"
-
-inherit distutils
-
-DESCRIPTION="Django recaptcha form field/widget app"
-HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-# Test not supported, missing dependency
-# test? ( >=dev-python/django-setuptest-0.0.6 )
diff --git a/dev-python/django-recaptcha/files/django-recaptcha-fields.patch b/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
index c4e722245434..2bd0d32c967e 100644
--- a/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
+++ b/dev-python/django-recaptcha/files/django-recaptcha-fields.patch
@@ -12,7 +12,7 @@ diff -ur django-recaptcha-0.0.6.orig/captcha/fields.py django-recaptcha-0.0.6/ca
from captcha import client
from captcha.widgets import ReCaptcha
-
-+from captcha import settings
++from captcha import test_settings as settings
class ReCaptchaField(forms.CharField):
default_error_messages = {
diff --git a/dev-python/django-recaptcha/files/django-recaptcha-settings.patch b/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
index 8cc2f979a5bc..c28694ee4d1a 100644
--- a/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
+++ b/dev-python/django-recaptcha/files/django-recaptcha-settings.patch
@@ -4,4 +4,3 @@
+RECAPTCHA_PUBLIC_KEY='76wtgdfsjhsydt7r5FFGFhgsdfytd656sad75fgh'
+RECAPTCHA_PRIVATE_KEY='98dfg6df7g56df6gdfgdfg65JHJH656565GFGFGs'
+RECAPTCHA_USE_SSL='True'
-
diff --git a/dev-python/django-recaptcha/files/test_settings.py b/dev-python/django-recaptcha/files/test_settings.py
new file mode 100644
index 000000000000..5e66d9e454a2
--- /dev/null
+++ b/dev-python/django-recaptcha/files/test_settings.py
@@ -0,0 +1,14 @@
+DATABASES = {
+ 'default': {
+ 'ENGINE': 'django.db.backends.sqlite3',
+ 'NAME': 'test.sqlite',
+ }
+}
+
+INSTALLED_APPS = [
+ 'captcha',
+]
+
+RECAPTCHA_PRIVATE_KEY = '98dfg6df7g56df6gdfgdfg65JHJH656565GFGFGs'
+RECAPTCHA_PUBLIC_KEY = '76wtgdfsjhsydt7r5FFGFhgsdfytd656sad75fgh'
+RECAPTCHA_USE_SSL='True'