summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-22 03:44:07 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-22 03:44:07 +0000
commit765e50a83b5c02e0f7b13521cb2de5b3604dd05f (patch)
treeb7684df8b56587fc0bf7910f2c220fcd6cceaa9a /dev-python/django
parentDrop redundant copy of ntp.conf. Remove cleanup code rendered obsolete by pre... (diff)
downloadgentoo-2-765e50a83b5c02e0f7b13521cb2de5b3604dd05f.tar.gz
gentoo-2-765e50a83b5c02e0f7b13521cb2de5b3604dd05f.tar.bz2
gentoo-2-765e50a83b5c02e0f7b13521cb2de5b3604dd05f.zip
postgres IUSE flag dropped and treated in the same as the dropped flag 'mysql' and the msg to use via the readme.gentoo extended
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog6
-rw-r--r--dev-python/django/django-1.7.ebuild11
2 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 384b39da44a5..1ea820f52240 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.148 2014/12/21 05:49:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.149 2014/12/22 03:44:07 idella4 Exp $
+
+ 22 Dec 2014; Ian Delaney <idella4@gentoo.org> django-1.7.ebuild:
+ postgres IUSE flag dropped and treated in the same as the dropped flag 'mysql'
+ and the msg to use via the readme.gentoo extended
21 Dec 2014; Ian Delaney <idella4@gentoo.org> django-1.7.ebuild:
drop IUSE mysql and dep dev-python/mysql-python in RDEPEND, substitute with
diff --git a/dev-python/django/django-1.7.ebuild b/dev-python/django/django-1.7.ebuild
index 19e2b7bf822b..efc15d35ece2 100644
--- a/dev-python/django/django-1.7.ebuild
+++ b/dev-python/django/django-1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.7.ebuild,v 1.3 2014/12/21 05:49:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.7.ebuild,v 1.4 2014/12/22 03:44:07 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -18,11 +18,10 @@ SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc postgres sqlite test"
+IUSE="doc sqlite test"
RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]' python2_7 python{3_3,3_4}) )"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
@@ -73,7 +72,9 @@ src_install() {
DOC_CONTENTS="Optional support for mysql as a backend to sql is available in the form of
dev-python/mysql-python for support of python 2.7 support, or dev-python/mysql-connector-python
- for support of python 2.7, 3.3 & 3.4. Just emerge the package to suit the needs."
+ for support of python 2.7, 3.3 & 3.4. Support of postgresql as a backend can be enabled via
+ emerging dev-python/psycopg:2 in cpythons 2.7 3.3 & 3.4 but not in pypy.
+ Just emerge the package to suit the needs."
readme.gentoo_create_doc
}