summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-08-01 16:44:53 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-08-01 16:44:53 +0000
commita0c0cf8a695d45e4dced704cb81e6f867a4b6fb5 (patch)
tree9d9a614b312fd417465f07b86605437d7d3becce /dev-python/django
parentVersion Bump. (diff)
downloadgentoo-2-a0c0cf8a695d45e4dced704cb81e6f867a4b6fb5.tar.gz
gentoo-2-a0c0cf8a695d45e4dced704cb81e6f867a4b6fb5.tar.bz2
gentoo-2-a0c0cf8a695d45e4dced704cb81e6f867a4b6fb5.zip
Version bump, bug #142375.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-0.95.ebuild38
-rw-r--r--dev-python/django/files/digest-django-0.953
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 7d582bd9e936..326c94772b7f 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.6 2006/07/28 11:59:49 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.7 2006/08/01 16:44:53 lucass Exp $
+
+*django-0.95 (01 Aug 2006)
+
+ 01 Aug 2006; Lukasz Strzygowski <lucass@gentoo.org> +django-0.95.ebuild:
+ Version bump, bug #142375.
28 Jul 2006; Alastair Tse <liquidx@gentoo.org> django-0.91.ebuild:
Preparing psycopg deps for slotted psycopg-2.0.2 (#125719)
diff --git a/dev-python/django/django-0.95.ebuild b/dev-python/django/django-0.95.ebuild
new file mode 100644
index 000000000000..95d3f4f11533
--- /dev/null
+++ b/dev-python/django/django-0.95.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.95.ebuild,v 1.1 2006/08/01 16:44:53 lucass Exp $
+
+inherit distutils
+
+MY_P="${PN/d/D}-${PV}"
+DESCRIPTION="high-level python web framework"
+HOMEPAGE="http://www.djangoproject.com/"
+SRC_URI="http://media.djangoproject.com/releases/${PV}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="sqlite postgres mysql"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/setuptools-0.6_rc1"
+
+RDEPEND=">=dev-lang/python-2.3
+ sqlite? ( >=dev-python/pysqlite-2.0.3 )
+ postgres? ( <dev-python/psycopg-1.99 )
+ mysql? ( dev-python/mysql-python )"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="docs/* AUTHORS INSTALL LICENSE"
+
+src_install()
+{
+ distutils_python_version
+
+ site_pkgs="/usr/$(get_libdir)/python${PYVER}/site-packages/"
+ export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
+ dodir ${site_pkgs}
+
+ distutils_src_install --single-version-externally-managed
+
+ cp -r examples "${D}/usr/share/doc/${PF}"
+}
diff --git a/dev-python/django/files/digest-django-0.95 b/dev-python/django/files/digest-django-0.95
new file mode 100644
index 000000000000..8d758bb9b360
--- /dev/null
+++ b/dev-python/django/files/digest-django-0.95
@@ -0,0 +1,3 @@
+MD5 9ed7d6a0daa147c012e31d0894802951 Django-0.95.tar.gz 1287781
+RMD160 95c405fff77e4a0cf51654e9d089a47b629dd875 Django-0.95.tar.gz 1287781
+SHA256 2185514d642f35d61d7c5c0a59545f2e18e41ee5abdb2912eafd64c1fa07c388 Django-0.95.tar.gz 1287781